Пустая страница при попытке доступа к phpmyadmin

10

Я хотел бы получить доступ к phpmyadmin. У меня есть доступ к нему раньше, но теперь я просто получаю пустую страницу, и я действительно не понимаю почему.

Я установил phpmyadmin, используя

sudo apt-get install phpmyadmin

Я запустил

sudo gedit /etc/apache2/apache2.conf

И добавил:

#Include phpmyadmin: 
 include /etc/phpmyadmin/apache.conf

Но я получал предупреждение, когда я перезапускаю apache, говоря мне:

The Alias directive in /etc/phpmyadmin/apache.conf at line 3 will probably never match because it overlaps an earlier Alias.

Как я могу это решить, чтобы снова увидеть интерфейс phpmyadmin, когда я Ссылка вместо того, чтобы видеть пустую веб-страницу?

Дамп -

  • Я пробовал apt-get remove phpmyadmin , а затем apt-get install phpmyadmin - все ту же пустую страницу. : (

  • /etc/phpmyadmin - У меня есть chmod o + w разрешения для папки phpmyadmin и ее содержимого. - все еще пустая страница ...

задан MEM 26.08.2011 в 13:09
источник

6 ответов

4

Попробуйте запустить

sudo dpkg-reconfigure phpmyadmin

Чтобы настроить файлы phpmyadmin, подключения к базе данных и создать базы данных phpmyadmin

    
ответ дан Ian Pettitt 13.09.2011 в 12:39
источник
17

Все предыдущие ответы мне не помогли, но затем я нашел решение:

apt install php-gettext

эта фиксированная проблема phpmyadmin белая пустая страница.     

ответ дан Roman 23.04.2016 в 04:32
0

Эта проблема возникла у меня, потому что я модифицировал php.ini (/etc/php5/apache/php.ini) и ввел неправильный формат. В частности, мне нужно было загрузить большой файл, поэтому я изменил эту строку:

upload_max_filesize = 2M

с:

upload_max_filesize = 20

Как вы можете видеть, я пропустил M. После перезапуска apache ( sudo service apache2 restart ) я получил пустую страницу.

** В общем, может быть, что ошибка в php.ini создает тихий (пустую страницу) вывод в php. **

    
ответ дан toto_tico 28.12.2013 в 04:44
0

Старый вопрос, который я знаю, но у меня недавно была та же проблема. Доступ к URL-адресу phpmyadmin дал пустую белую страницу. Журналы apache не показали ничего плохого. Все заголовки ответов были «200 OK».

Проблема была простой, я отключил javascript в браузере.

Чтобы исправить в firefox, введите url 'about: config', найдите ключ с именем javascript.enabled и переведите его в true.

В хроме, перейдите к настройке > Дополнительные настройки > Настройки содержимого, прокрутите вниз до заголовка Javascript и установите флажок «Включить javascript».

    
ответ дан Twifty 27.02.2015 в 16:15
0

Когда я изменил это внутри config.inc.php:

$cfg['UploadDir'] = '/tmp'; $cfg['SaveDir'] = '/tmp';

в

$cfg['UploadDir'] = ''; $cfg['SaveDir'] = '';

и перезагрузили страницу, после чего она работала напрямую!

    
ответ дан Tim B. 24.08.2017 в 12:16
-1

Моя проблема была другая: страница была белой, но, проверяя HTML, я мог видеть поля входа и пароля. Проблема была в пространстве на жестком диске:

No space left on device

Освобождение некоторых сделанных phpMyAdmin снова.

    
ответ дан Paolo 19.02.2017 в 09:31