Google Планета Земля не устанавливается на 14.04

9

Я пытаюсь установить Google Earth на Ubuntu 14.04 и получить следующую ошибку. Проблема связана с использованием dpkg -i для установки загрузок .deb с сайта Google, а также я тестировал с помощью программного обеспечения Ubuntu Software .

Существует аналогичные вопросы на этом сайте, говорящие о проблемах с установкой, но ни один из них не включен в 14.04, поэтому я решил опубликовать новые вопросы, касающиеся подсказок-решений для текущей версии LTS Ubuntu (большинство комментариев и предложений в этих предыдущих вопросах предназначенные для самых старых версий Ubuntu)

Preparing to unpack google-earth-stable_current_amd64.deb ...
Unpacking google-earth-stable (7.1.2.2041-r0) ... dpkg: dependency
problems prevent configuration of google-earth-stable: 
google-earth-stable depends on lsb-core (>= 3.2); however:   Package
lsb-core is not installed.  google-earth-stable depends on ia32-libs;
however:   Package ia32-libs is not installed.

dpkg: error processing package google-earth-stable (--install): 
dependency problems - leaving unconfigured Processing triggers for
man-db (2.6.7.1-1) ... Processing triggers for bamfdaemon
(0.5.1+14.04.20140409-0ubuntu1) ... Rebuilding
/usr/share/applications/bamf-2.index... Processing triggers for
gnome-menus (3.10.1-0ubuntu2) ... Processing triggers for
desktop-file-utils (0.22-1ubuntu1) ... Processing triggers for
mime-support (3.54ubuntu1) ... Errors were encountered while
processing:  google-earth-stable

Выполнение описанного здесь Я получил:

sudo dpkg -i google-earth-stable_current_amd64.deb  Selecting
previously unselected package google-earth-stable. (Reading database
... 277661 files and directories currently installed.) Preparing to
unpack google-earth-stable_current_amd64.deb ... Unpacking
google-earth-stable (7.1.2.2041-r0) ... dpkg: dependency problems
prevent configuration of google-earth-stable:  google-earth-stable
depends on lsb-core (>= 3.2); however:   Package lsb-core is not
installed.  google-earth-stable depends on ia32-libs; however:  
Package ia32-libs is not installed.

dpkg: error processing package google-earth-stable (--install): 
dependency problems - leaving unconfigured Processing triggers for
man-db (2.6.7.1-1) ... Processing triggers for bamfdaemon
(0.5.1+14.04.20140409-0ubuntu1) ... Rebuilding
/usr/share/applications/bamf-2.index... Processing triggers for
gnome-menus (3.10.1-0ubuntu2) ... Processing triggers for
desktop-file-utils (0.22-1ubuntu1) ... Processing triggers for
mime-support (3.54ubuntu1) ... Errors were encountered while
processing:  google-earth-stable
    
задан gsi-frank 28.04.2014 в 04:58
источник

6 ответов

16

Попробуйте метод здесь , чтобы установить Google Earth

Проблема с Google Планета Земля заключается в том, что 32-битный пакет не поддерживает многоархиво, поэтому он не устанавливает все 32-разрядные зависимости, необходимые для работы на 64-битной версии Ubuntu.

Я рекомендую вам просто скопировать вставку следующую команду:

sudo apt-get install libfontconfig1:i386 libx11-6:i386 libxrender1:i386 libxext6:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libglib2.0-0:i386 libsm6:i386; cd /tmp && wget http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb; sudo dpkg -i google-earth-stable_current_i386.deb; sudo apt-get install -f

Затем загрузите и установите 32-битный программный пакет на 64-разрядную систему.

    
ответ дан ray 28.04.2014 в 05:07
источник
3

Это работает для kubuntu 14.04 AMD64 в моей системе

  1. Загрузите 32-битный пакет (верьте мне, пакет amd64 бит НЕ действительно 100% 64-бит-тобой на google, как долго длится 64 бит?)
  2. Установите пакет google .deb
  3. Откройте терминал и запустите следующую команду:

    sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 libglu1-mesa:i386 libgl1-mesa-glx:i386 libxext6:i386 libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core
    
  4. Вот он, теперь он должен работать без ошибок. Из командной строки, run google-earth

Ссылка: GoogleEarth

    
ответ дан user286904 30.05.2014 в 17:14
2

Похоже, что ia32-libs (которого хочет Google Earth) больше не существует. Однако он был заменен! Это сработало для меня (Ubuntu 14.04 LTS, установка google-earth-stable_current_amd64.deb):

Откройте окно терминала и скопируйте:

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0

После этого google-earth-stable_current_amd64.deb будет установлен без ошибок.

    
ответ дан Martin Norgaard 15.09.2014 в 17:05
2

Я - пользователь Ubuntu 14.04, 64-разрядный. Я потратил около 2 дней в Интернете, чтобы получить решение по этой проблеме. Я пробовал почти все данные предложения, включая решение Webupd8, но не смог найти решение.

Наконец я нашел решение ниже, и теперь Google Earth работает безупречно на моем ПК. Теперь я могу искать в Google Планета Земля без проблем, и я даже не сталкиваюсь с проблемой «пустого кадра».

Решение:

  1. Удалите предыдущие версии Google Планета Земля. Я использовал диспетчер пакетов Synaptic для удаления Google Планета Земля.

  2. Установите ia32-libs :

    sudo -i
    cd /etc/apt/sources.list.d
    echo "deb http://old-releases.ubuntu.com/ubuntu/ raring main restricted universe multiverse" >ia32-libs-raring.list
    apt-get update
    apt-get install ia32-libs
    

    P.S: В конце вы можете удалить ia32-libs-raring.list в /etc/apt/sources.list.d , а затем обновить систему, набрав команду sudo apt-get update .

  3. Затем перейдите в ссылку Mint и загрузите версию googleearth_6.2.2.6613-r0_i386.deb и установите ее с терминала набрав:

    sudo gdebi googleearth_6.2.2.6613-r0_i386.deb  
    
  4. После завершения установки запустите эту команду: google-earth .

  5. После запуска Google Планета Земля и поиска определенного города в окне поиска и столкновения с проблемой, например: invalid HTTP request , выполните следующие действия в терминале:

    sudo mv /opt/google/earth/free/libcurl.so.4 /opt/google/earth/free/backup_libcurl.so.4   
    

Google Планета Земля должна работать правильно, она действительно работала на моем ПК, как шарм.

    
ответ дан Xalid Cibran 20.04.2015 в 17:22
1

Я запускаю Ubuntu 14.04 (64 бит) и имел ту же проблему. 32-битная версия GE работала для меня до некоторой степени, но изображения panaramo не загружались в GE. Я нашел ответ, который здесь работал для того, чтобы получить 64-разрядную работу (среди прочего, вы удаляете линию зависимостей): Ссылка

    
ответ дан user242234 21.01.2015 в 20:02
0

Я решил проблему, используя это

Google Earth Установите x64 в Linux Mint 18 Cin

После того, как я решил, я начал танцевать с песней принца «Поцелуй»

    
ответ дан Ted Taylor of Life 17.04.2017 в 21:07