Изменить десятичную метку в калькуляторе

11

В Германии мы используем , в качестве десятичной метки вместо . . Поскольку я установил свой Ubuntu на английском языке, калькулятор по умолчанию Ubuntu ( gcalctool ) использует . , и я не могу использовать , на моей немецкой цифровой клавиатуре.

Я уже настроил немецкий в System Settings... = > Language Support = > Regional Formats , но, похоже, он не настроил его для калькулятора. Я также видел этот вопрос , но я хочу чтобы избежать переназначения моих ключей.

Может кто-нибудь сказать мне, если и как я могу изменить это для калькулятора или рекомендовать калькулятор, который его поддерживает?

    
задан André Stannek 01.02.2013 в 16:32
источник

1 ответ

8

Иногда это легко. Вдохновленный @Lucio, который сказал, что это должно работать, я перезагрузился, и теперь это происходит. Теперь я также увидел, что он говорит « Changes take effect next time you log in. ». Сначала прочитайте, затем спросите. Должно было сделать это в первую очередь, извините за это!

Итак, для всех, кто хочет достичь того же:

  • Перейдите к System Settings... = > Language Support
  • Убедитесь, что язык для языкового стандарта вашего формата установлен. Вы можете установить его с помощью кнопки Install/Remove Languages
  • Перейдите на вкладку Regional Formats и выберите свою страну.
  • Нажмите Apply System-Wide
  • Reboot! (Или выйти из системы и вернуться. Должен также работать).

Калькулятор по умолчанию теперь должен принимать десятичную метку, используемую в вашей локали.

    
ответ дан André Stannek 01.02.2013 в 17:39
источник