Atheros AR9462 WiFI очень неустойчиво и потеря пакетов

10

У меня серьезные проблемы с потерей пакетов и вообще плохое соединение с WiFi-сетью на моем uni. Обычно я сталкиваюсь с потерей пакетов ~ 50% и прерыванием соединений, что делает невозможным работу с SaaS.

Я использую Ubuntu 13.04, а мой сетевой адаптер - Atheros AR9462.

Применение параметра nohwcrypt = 1 ничего не меняет.

Также очень примечательно: соединение работает по назначению в других сетях; в проблемной сети используется WPA2 w / MSCHAPv2.

Кто-нибудь может помочь мне здесь?

$ sudo lshw -class network  *-network UNCLAIMED     
       description: Ethernet controller
       product: NetLink BCM57780 Gigabit Ethernet PCIe
       vendor: Broadcom Corporation
       physical id: 0
       bus info: [email protected]:04:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:d3500000-d350ffff
  *-network
       description: Wireless interface
       product: AR9462 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: [email protected]:09:00.0
       logical name: wlan0
       version: 01
       serial: e0:06:e6:76:ba:89
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.8.0-22-generic firmware=N/A ip=131.173.74.130 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:19 memory:d3400000-d347ffff memory:9fb00000-9fb0ffff
    
задан user1004816 29.05.2013 в 10:46
источник

5 ответов

2

Похож на ошибку в сетевом менеджере. Ошибка

Запустите эту команду в терминале:

sudo gedit /etc/NetworkManager/system-connections/essid  

В том месте, где говорится, что в указанной выше команде essid введите имя вашей беспроводной сети. Файл должен открыть, затем введите свой пароль пользователя, изменив строку «system-ca-certs = true» на «system-ca-certs = false», сохраните и закройте gedit или любой текстовый редактор, который вы используете, затем перезагрузитесь.

Затем подключитесь, как обычно, используя диспетчер сети.

Также некоторые люди просто удалили «system-ca-certs = true» из файла, который работал для них, но несколько человек сообщили, что файл воссоздается при перезагрузке, поэтому я предлагаю изменить true на false вместо удаления строки полностью.

Если вы не используете gedit в качестве текстового редактора в приведенной выше команде, введите имя редактора, который вы используете вместо gedit.

    
ответ дан Wild Man 18.08.2013 в 19:52
2

У меня есть Acer V5-131 с AR9462. Он работал для некоторых точек доступа, но вырезался / снова подключался к другим. Это строка в /etc/modprobe.d/ath9k.conf , которая исправила ее для меня:

options ath9k nohwcrypt=1 blink=1 btcoex_enable=1

Удачи.

    
ответ дан JeffM in Honolulu 30.08.2013 в 04:57
0
options ath9k nohwcrypt=1 blink=1 btcoex_enable=1

вместо

options ath9k nohwcrypt=1 

в /etc/modprobe.d/ath9k.conf

Работайте как шарм для Acer Aspire S3-391

    
ответ дан Eric Lan 08.12.2013 в 05:21
0

Не удалось заставить мою беспроводную сеть AR9462 работать корректно без капли через тридцать минут с предложениями выше на ASUS X201E, которые поставлялись с 12.04 на любое ядро ​​после 3.2.0-54.

Наконец наткнулся на это и обновил мое ядро ​​до 3.12.2-031202-generic, и все отлично работает. Если вы установите это, и он не работает, вы можете вернуться к предыдущему ядру при загрузке. Как здесь: Ссылка

    
ответ дан elmus 09.12.2013 в 01:08
0

Изменение моего канала маршрутизатора на 1 фиксировало именно эту проблему для моего беспроводного AR9462. Ни один из вариантов ath9k не имел никакого эффекта.

    
ответ дан chrisf 07.01.2014 в 08:35