Сделать цвета встроенных терминалов gedit такими же, как терминал по умолчанию

31

Я только что обновил до 11.10, и теперь мой встроенный терминал в gedit не соответствует моему терминалу по умолчанию. Я ненавижу смотреть на белый и черный терминал. Кто-нибудь знает, как заставить встроенный терминал соответствовать терминалу по умолчанию?

Это скриншот:

Я хочу, чтобы мой встроенный терминал в gedit соответствовал моему терминалу по умолчанию.

    
задан Hugo 16.10.2011 в 16:10
источник

6 ответов

36
  1. Убедитесь, что установлены следующие пакеты:

  2. Откройте gconf-editor и перейдите в apps ➜ gnome-terminal и выберите профиль:

  3. Теперьоткройтеdconf-editorиперейдитекorg➜gnome➜gedit➜plugins➜terminalиснимитефлажокuse-theme-colors:

  4. Из gconf-редактора скопируйте значения

    • цвет фона
    • передний план цвет
    • палитра

    до соответствующих клавиш в dconf-редакторе. Теперь встроенный терминал должен соответствовать регулярному терминалу gnome.

ответ дан Isaiah 19.10.2011 в 23:20
источник
18

Это для gedit 3

Такая же проблема здесь белая на светло-сером.

Я вручную отредактировал /usr/lib/gedit/plugins/terminal.py . Используемый терминал - xterm.

Искать:

fg = context.get_color(Gtk.StateFlags.NORMAL)
bg = context.get_background_color(Gtk.StateFlags.NORMAL)

Я заменяю

fg = Gdk.RGBA(0, 0, 0, 1)
bg = Gdk.RGBA(1, 1, 1, 1)

Информация: fg = черный текст, bg = белый фон

    
ответ дан John 10.07.2012 в 14:10
4

Убедитесь, что вы не отметили Использовать цвета из системной темы , тогда она должна работать:

    
ответ дан htorque 14.04.2011 в 20:11
1

Откройте gconf-editor и перейдите к apps->gnome-terminal->profiles->Default

  • Снимите флажок Use-theme-colors.
  • Установить цвет переднего плана: #FFFFFF
  • Установить цвет фона: # 000000

Это приведет к тому, что текст будет белым, а фон - черным. Он установит это как для терминала, так и для встроенного терминала, если вы хотите использовать разные цвета для каждого, тогда сделайте это вместо этого.

Откройте gconf-editor и перейдите к apps->gedit-2->plugins

  • Создайте новый ключ с именем use_theme_colors
  • Задайте тип: Boolean
  • Задайте значение: False
  • Создайте новый ключ с именем foreground_color
  • Задайте тип: Строка
  • Установите значение: #FFFFFF
  • Создайте новый ключ с именем background_color
  • Задайте тип: Строка
  • Задайте значение: # 000000

Отредактируйте файл /usr/lib/gedit-2/plugins/terminal.py

Под строкой:

GCONF_PROFILE_DIR = "/apps/gnome-terminal/profiles/Default"

Добавьте новую строку:

GCONF_GEDIT_DIR = "/apps/gedit-2/plugins"

Затем замените строки:

if not gconf_get_bool(self.GCONF_PROFILE_DIR + "/use_theme_colors"):
fg_color = gconf_get_str(self.GCONF_PROFILE_DIR + "/foreground_color", None)
bg_color = gconf_get_str(self.GCONF_PROFILE_DIR + "/background_color", None)

С

if not gconf_get_bool(self.GCONF_GEDIT_DIR + "/use_theme_colors"):
fg_color = gconf_get_str(self.GCONF_GEDIT_DIR + "/foreground_color", None)
bg_color = gconf_get_str(self.GCONF_GEDIT_DIR + "/background_color", None)

Теперь вы можете установить цвета только для встроенного терминала, а ключи, созданные в apps->gedit-2->plugins

    
ответ дан Gary 12.11.2015 в 13:33
1

Проверяя terminal.py для Ubuntu 16.04, кажется, что он загружает некоторый старый профиль:

def get_profile_settings(self):
    profiles = self.settings_try_new("org.gnome.Terminal.ProfilesList")

    if not profiles:
        default_path = "/org/gnome/terminal/legacy/profiles:/:" + profiles.get_string("default") + "/"
        settings = Gio.Settings.new_with_path("org.gnome.Terminal.Legacy.Profile",
                                              default_path)
    else:
        settings = Gio.Settings.new("org.gnome.gedit.plugins.terminal")

    return settings

Проверяя org.gnome.terminal.legacy.profiles: в dconf-editor , был такой профиль. После удаления с помощью:

dconf reset -f /org/gnome/terminal/legacy/profiles:/

Я могу изменить настройки в org.gnome.gedit.plugins.terminal и заставить их вступить в силу. Для background-color мне пришлось сначала отключить use-theme-colours .

    
ответ дан muru 16.01.2017 в 05:52
0

в 13.04, путь редактора gconf к свойствам изменился на: org - > gnome - > gedit - > Терминал

    
ответ дан Nico Grunfeld 25.07.2013 в 23:35