Bumblebee Intel + Nvidia по номеру 15.10

9

У меня есть новая версия Kubuntu 15.10, у меня есть ноутбук msi GT70 с оптимизмом.

Я установил bumblebee bumblebee-nvidia , это абсолютно необходимо, потому что nouveau продолжает сбой при входе в систему.

Итак, я отредактировал /etc/bumblebee/bumblebee.conf

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when     Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-    gnu/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-304
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-304:/usr/lib32/nvidia-304
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-304/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

У меня

$ cat /proc/acpi/bbswitch 
0000:01:00.0 ON

Я поместил в /etc/modules-load.d/modules.conf

i915
bbswitch

Итак, я могу сделать:

$ primusrun glxinfo | grep "OpenGL version"
OpenGL version string: 4.2.0 NVIDIA 304.128

Но , если я перезагружу все, что у меня есть, это черный экран , чтобы запустить мою систему, я должен войти в tty1 и сделать:

sudo modprobe nvidia_304
sudo service sddm restart

, чтобы получить экран входа в kubuntu любые идеи, чтобы исправить это?

Также, если я заменил nvidia-304 на nvidia-355 , я не могу загрузиться вообще: подсказка modprobe не работает.

Вот моя конфигурация с lspci :

$ lspci|grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK104M [GeForce GTX 870M] (rev ff)

EDIT:

Некоторая связанная информация и потенциальное исправление Ссылка (по-итальянски) Ссылка

Также есть ошибка с модулем i915 на ядре 4.2 Ссылка

EDIT2 (рабочее решение шмеля):

Мне удалось выполнить эту работу Ссылка

  1. установить nvidia-355 и nvidia-prime
  2. выберите драйвер intel в панели nvidia и выйдите из системы
  3. установить только шмелю (не шмели-nvidia)
  4. отредактировать при необходимости /etc/bumblebee/bumblebee.conf line22 KernelDriver = nvidia замените nvidia-current на nvidia-355
  5. /etc/bumblebee/xorg.conf.nvidia uncomment BusID "PCI: 01: 00: 0" как описано здесь Ссылка ,
  6. Теперь вы можете загрузиться с помощью карты intel и использовать optirun и primusrun. Он работает для меня до сих пор, тест с primusrun glxinfo

EDIT3: ( май 03/12/2015 )

Используя ppa: graphics-drivers / ppa и ppa: xorg-edgers / ppa , после обновления и перезагрузки у меня был черный экран с использованием 358.16- 0ubuntu0 ~ gpu15.10.2 .

Итак, я очистил все, а затем просто установил bumblee-nvidia nvidia-358 , отредактировал /etc/bumblebee/bumblebee.conf и сделал sudo service bumblebeed restart .

Он снова работал после перезагрузки.

    
задан Kwaadpepper 25.10.2015 в 22:37
источник

3 ответа

9

Поскольку у вас есть совершенно новое оборудование для GPU, вам также следует использовать новые драйверы и программное обеспечение NVIDIA.

Замените шмеля на nvidia-prime , чтобы переключаться между встроенной и выделенной графикой .

Переустановите драйверы NVIDIA, но сначала удалите все программное обеспечение NVIDIA и удалите шмеля.

Откройте терминал и выполните:

sudo apt-get purge nvidia* '^bumblebee.*'  
sudo reboot  

Когда появится меню загрузки GRUB : выделите пункт меню Ubuntu и нажмите клавишу E .
Добавьте параметр nouveau.modeset=0 в конец строки Linux ... Затем нажмите F10 для загрузки.

Установите стабильные проприетарные драйверы NVIDIA из репозиториев Ubuntu (не относится к ubuntu 12.04:

sudo apt-get update
sudo apt-get install nvidia-352 nvidia-prime
sudo reboot

Если вы хотите использовать последние версии драйверов - установите их из проприетарных графических процессоров PPA:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-355 nvidia-prime
sudo reboot  
    
ответ дан cl-netbox 26.10.2015 в 13:36
источник
7

Хотя все, казалось, сработало, попробовав следующие шоу, bbswitch не может корректно отключить карту nvidia:

cat /proc/acpi/bbswitch
primusrun glxinfo|grep OpenGL
sleep 1
cat /proc/acpi/bbswitch

Затем я переустановил bumblebee-nvidia, он работал, пока я не перезапустил систему. Покопавшись еще немного о проблеме, я заметил, что обновления обновления обновляются после перезагрузки системы, и я заметил, что это вызывает gpu-manager. (просто запустите «sudo gpu-manager», и вы увидите, что он обновлен)

gpu-manager запускается после запуска lightdm. поэтому, в качестве быстрого обходного пути, я отключил его.

теперь все работает так, как ожидалось. после запуска чего-то с optirun или primusrun, bbswitch корректно выключает nvidia, когда процесс завершается.

Подводя итог, вот мое резюме, чтобы установить все с нуля (запустите его вручную, прочитав комментарии):

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

sudo apt-get purge -y nvidia* bumblebee bumblebee-nvidia bbswitch-dkms primus
sudo apt-get install nvidia-355

#switch to intel
sudo tee /etc/prime-discrete <<< off

#reboot is recommended at this point

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee primus

#sudo gedit /etc/modules
#  add the line "bbswitch load_state=0"

#sudo gedit /etc/modprobe.d/bumblebee.conf
#and make sure the following line exists
#  blacklist nvidia-355

#sudo gedit /etc/bumblebee/bumblebee.conf
#  change line 22 "Driver=" to "Driver=nvidia"
#  change all nvidia-current to nvidia-355

#sudo gedit /etc/bumblebee/xorg.conf.nvidia
#  uncomment BusID line if it is commented and make sure it corresponds to the correct BusID

#disable gpu-manager as it changes i386-linux-gnu_gl_conf and x86_64-linux-gnu_gl_conf
sudo systemctl mask gpu-manager.service

EDIT: Я удалил модификации rc.local, потому что gpu-manager запускался не только во время выполнения, но и при использовании системы. Поэтому я полностью отключил его.

    
ответ дан Gokhan Moral 27.12.2015 в 09:47
6

Удалось заставить шмеля работать в Уайли после слишком много ненужных головных болей, без этого ужасающего ужаса.

Как подозревали другие, это из-за gpu-manager. Независимо от того, что это такое, он работает по всей альтернативной конфигурации обновлений. Маскировка этой службы и переустановка шмеля [-nvidia] устраняет все проблемы, теперь карта включается и выключается с помощью optirun, как и ожидалось, и больше нет черных экранов при загрузке.

sudo systemctl mask gpu-manager.service
sudo apt-get install --reinstall bumblebee bumblebee-nvidia

Также убедитесь, что не осталось сломанного /etc/X11/xorg.conf.

    
ответ дан Luca Boccassi 28.12.2015 в 22:53