Установщик перезагружается на «Обнаружение оборудования» (диски и другое оборудование) на всех последних установках сервера

10

У меня очень неприятная проблема с моим ПК. Я не могу установить последнюю версию Ubuntu Server (или даже Desktop) с 9.04 даже с помощью текстового установщика. Я загружаюсь с USB-накопителя, созданного Unetbootin (я также пробовал другие методы, такие как создатель автозагрузки без разницы).

В установщике сервера он получает «Обнаружение оборудования» (второй - о дисках и всем другом аппаратном обеспечении, а не о сетевом оборудовании), а затем либо зависает на 0% (ожидается 24 часа), либо перезагружается через минуту или две .

Моя система (конец 2007 года):

  • Материнская плата ASUS P5NSLI
  • Intel Core 2 Duo E6600 2.4Ghz
  • 2 x 1GB Corsair 667MHz RAM
  • nVidia GeForce 6600

Я отключил все (включая единственный жесткий диск, CD-ROM и дискету). У меня есть только один палец ОЗУ (попробовал каждый из них безрезультатно) и загружаю установщик с USB-накопителя (загрузка с CD-ROM дает ту же проблему). Я также попробовал несколько вариантов загрузки ( nomodeset , nousb , acpi=off , noapic , i915.modeset=1/0 , xforcevesa ) во всех комбинациях) безрезультатно. Единственными активными частями моей системы являются видеокарта, мышь, клавиатура и USB-накопитель.

Я также обновил BIOS до самой последней версии.

(FWIW, на установщике рабочего стола, я получаю черный экран после нажатия кнопки «Установка».)

Даже после удаления «тишины» я не могу понять, какая паника ядра происходит (или не возникает), чтобы привести к сбою установки. Я могу сохранить журналы отладки через простой веб-сервер в установщике. После последней строки (я многократно обновляюсь) сервер перестает отвечать на запросы, и установщик зависает или перезагружается:

Jan  2 01:04:03 main-menu[302]: INFO: Menu item 'disk-detect' selected
Jan  2 01:04:04 kernel: [  309.154372] sata_nv 0000:00:0e.0: version 3.5
Jan  2 01:04:04 kernel: [  309.154409] sata_nv 0000:00:0e.0: Using SWNCQ mode
Jan  2 01:04:04 kernel: [  309.154531] sata_nv 0000:00:0e.0: setting latency timer to 64
Jan  2 01:04:04 kernel: [  309.164442] scsi0 : sata_nv
Jan  2 01:04:04 kernel: [  309.167610] scsi1 : sata_nv
Jan  2 01:04:04 kernel: [  309.167762] ata1: SATA max UDMA/133 cmd 0x9f0 ctl 0xbf0 bmdma 0xd400 irq 10
Jan  2 01:04:04 kernel: [  309.167774] ata2: SATA max UDMA/133 cmd 0x970 ctl 0xb70 bmdma 0xd408 irq 10
Jan  2 01:04:04 kernel: [  309.167948] sata_nv 0000:00:0f.0: Using SWNCQ mode
Jan  2 01:04:04 kernel: [  309.168071] sata_nv 0000:00:0f.0: setting latency timer to 64
Jan  2 01:04:04 kernel: [  309.171931] scsi2 : sata_nv
Jan  2 01:04:04 kernel: [  309.173793] scsi3 : sata_nv
Jan  2 01:04:04 kernel: [  309.173943] ata3: SATA max UDMA/133 cmd 0x9e0 ctl 0xbe0 bmdma 0xe800 irq 11
Jan  2 01:04:04 kernel: [  309.173954] ata4: SATA max UDMA/133 cmd 0x960 ctl 0xb60 bmdma 0xe808 irq 11
Jan  2 01:04:04 kernel: [  309.174061] pata_amd 0000:00:0d.0: version 0.4.1
Jan  2 01:04:04 kernel: [  309.174160] pata_amd 0000:00:0d.0: setting latency timer to 64
Jan  2 01:04:04 kernel: [  309.177045] scsi4 : pata_amd
Jan  2 01:04:04 kernel: [  309.178628] scsi5 : pata_amd
Jan  2 01:04:04 kernel: [  309.178801] ata5: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xf000 irq 14
Jan  2 01:04:04 kernel: [  309.178811] ata6: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xf008 irq 15
Jan  2 01:04:04 net/hw-detect.hotplug: Detected hotpluggable network interface eth0
Jan  2 01:04:04 net/hw-detect.hotplug: Detected hotpluggable network interface lo
Jan  2 01:04:04 kernel: [  309.485062] ata3: SATA link down (SStatus 0 SControl 300)
Jan  2 01:04:04 kernel: [  309.633094] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Jan  2 01:04:04 kernel: [  309.641647] ata1.00: ATA-8: ST31000528AS, CC38, max UDMA/133
Jan  2 01:04:04 kernel: [  309.641658] ata1.00: 1953525168 sectors, multi 1: LBA48 NCQ (depth 31/32)
Jan  2 01:04:04 kernel: [  309.657614] ata1.00: configured for UDMA/133
Jan  2 01:04:04 kernel: [  309.657969] scsi 0:0:0:0: Direct-Access     ATA      ST31000528AS     CC38 PQ: 0 ANSI: 5
Jan  2 01:04:04 kernel: [  309.658482] sd 0:0:0:0: Attached scsi generic sg0 type 0
Jan  2 01:04:04 kernel: [  309.658588] sd 0:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
Jan  2 01:04:04 kernel: [  309.658812] sd 0:0:0:0: [sda] Write Protect is off
Jan  2 01:04:04 kernel: [  309.658823] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
Jan  2 01:04:04 kernel: [  309.658918] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Jan  2 01:04:04 kernel: [  309.675630]  sda: sda1 sda2
Jan  2 01:04:04 kernel: [  309.676440] sd 0:0:0:0: [sda] Attached SCSI disk
Jan  2 01:04:05 kernel: [  309.969102] ata2: SATA link down (SStatus 0 SControl 300)
Jan  2 01:04:05 kernel: [  310.281137] ata4: SATA link down (SStatus 0 SControl 300)

У кого-нибудь есть какие-то дополнительные идеи, которые я мог бы попробовать? Я собираюсь просто бросить материнскую плату.

    
задан Ryan Rosario 12.02.2012 в 21:25
источник

3 ответа

1

Кажется, это связано с вашими дисками. Некоторые Bioses имеют возможность настройки режима контроллера диска. Между «современным» и наследием. Проверьте свою биографию, если у вас есть такой вариант. Попробуйте переключить его и посмотрите, будет ли программа установки больше.

    
ответ дан tomodachi 21.03.2012 в 23:33
0

Я нашел это обсуждение аналогичной проблемы, которая была устранена путем отключения функций RAID в BIOS.

Ссылка

Основываясь на руководстве для вашей материнской платы ( Ссылка ), вы должны перемещаться до Advanced > Конфигурация бортовых устройств > NVRAID Конфигурирование и отключение NVRAID.

Если это не сработает, попробуйте ли вы поменять источник питания? Я видел множество проблем, включая проблемы с диском, подобные этому, вызванные проблемами энергоснабжения. Это определенно стоит попробовать.

Вы говорите, что проблема возникает даже без дисков в системе? Когда вы тестировали без дисков, вы использовали оптический привод или USB-накопитель? Мне особенно интересно узнать, подключены ли какие-либо устройства SATA. Если бы вы это сделали, было бы интересно протестировать без приводов и USB-накопителя, чтобы увидеть, можете ли вы воссоздать сбой. Было бы также интересно попробовать установщик с диском PATA и посмотреть, можете ли вы установить на него.

    
ответ дан johnf 22.03.2012 в 01:26
0

У вас есть другой компьютер, на котором вы можете полностью установить Ubuntu GNU / Linux, обновить его полностью. Затем поставьте этот диск на компьютер для этого сообщения, чтобы узнать, загружается ли он / работает? Вот что я хотел бы попробовать.

Кроме того, я бы попробовал разное ОЗУ (если доступно). Кроме того, будет успешно установлена другая дистрибутива? И успешно ли загружается LiveCD на рабочий стол?

Кроме того, у меня есть более старая материнская плата с загруженным на ней Ubuntu, который перейдет в цикл перезагрузки, поскольку способ загрузки RAID-контроллера при загрузке. Был некоторый конфликт, в котором BIOS BIOS мог бы помешать загрузочным секторам на диске SATA. Есть какой-то способ использовать dd для перемещения загрузочного сектора и исправить его, но то, что я закончил, было подключением старого маленького диска IDE, который у меня был, и установки для него / boot (только) для него для Ubuntu. Работал с тех пор. Я вижу из вашего мобильного изображения , что у вас есть IDE-слот, так что, возможно, если у вас нет способа отключите RAID, вы можете попробовать установить на жесткий диск IDE для тестирования.

В этом сообщении об ошибке есть история (и возможная ссылка на обходной путь) для проблема, с которой я столкнулся.     

ответ дан Shannon_VanWagner 29.04.2012 в 04:28