Как заставить telnet работать с localhost?

10

Я работаю над локальной установкой dev, которая требует использования telnet (играя с настройкой MUD-сервера), поэтому, пожалуйста, никаких отзывов о том, что я использую SSH как более безопасную альтернативу.

Однако, хотя у меня есть демон telnet, я получаю этот вывод, когда я telnet localhost.

$ telnet localhost
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.

Каковы некоторые причины закрытия соединения? Я проверил документы на hosts.allow и hosts.deny и решил не помещать любые записи ни по умолчанию, ни по умолчанию, чтобы разрешить все, и этого достаточно для моих локальных целей dev.

    
задан jerome 28.12.2012 в 02:30
источник

3 ответа

2

Хорошо, давайте расследуем это, шаг за шагом. Чтобы выяснить, что на самом деле работает на порту telnet, введите:

sudo netstat -tulpn | grep :23

и вставьте результат.

С другой стороны: какую библиотеку игр PHP вы используете?

    
ответ дан 0xF2 12.01.2013 в 01:36
1

Примечание: Я только что искал MUD-сервер с библиотекой игр NAGS и нашел это: nags-php-mud . Мой ответ не имеет значения, если вы используете что-то еще.

У config.php была следующая конфигурация:

<?
    /*Modify the setting here to set up your game server */
    $configarray = array(
        'DB_HOST' => 'localhost',
        'DB_USERNAME' => 'nags',
        'DB_PASSWORD' => 'password',
        'DB_DATABASE' => 'nags',
        'IP_ADDRESS' => '0.0.0.0',
        'SERVER_PORT' => '4000',
        'SERVER_NAME' => 'NAGS GAMING SYSTEM',
);?>

Итак, номер порта 4000. Можете ли вы попробовать обновить IP-адрес до 127.0.0.1 , а затем подключиться к порту 4000 с помощью telnet: telnet 127.0.0.1 4000

Обновление
В приведенной выше команде у вас есть telnet localhost , а не telnet localhost 4000 .
Я попытался запустить его, но у меня проблема. Он отображает следующее, и я не могу его проследить:

PHP Notice:  Undefined index: quiet in /home/blvdeer/Downloads/nags-php-mud-master/nags.php on line 34  
PHP Notice:  Undefined index: q in /home/blvdeer/Downloads/nags-php-mud-master/nags.php on line 34
PHP Notice:  Undefined index: deamon in /home/blvdeer/Downloads/nags-php-mud-master/nags.php on line 38
PHP Notice:  Undefined index: d in /home/blvdeer/Downloads/nags-php-mud-master/nags.php on line 38
PHP Notice:  Undefined property: MAIN::$MESSAGE in /home/blvdeer/Downloads/nags-php-mud-master/modules/main.php on line 158
SYSTEM: (LOAD MODULE)   MESSAGE
SYSTEM: (LOAD MODULE)   CONFIGURE
SYSTEM: (LOAD MODULE)   DATABASE
    
ответ дан blvdeer 12.01.2013 в 18:23
-2

Попробуйте с telnet localhost 80 Где 80 - это порт, на котором работает ваш сервер. Я попытался использовать порт 80 для сервера Apache, и он работает.

Также вам может понадобиться использовать -K и -X. Узнайте больше о них в man telnet

    
ответ дан Abhijit Navale 06.01.2013 в 04:08