Как отключить автоматическое предупреждение о приостановке

10

Я использую ubuntu 13.10 как htpc. Чтобы сохранить некоторую мощность, я отключил ее после 30 минут бездействия. Перед входом в приостановленное состояние появляется всплывающее окно, предупреждающее меня, что компьютер собирается спать. Это немного раздражает, так как появляется, когда я возобновляю компьютер позже.

Как я могу отключить это уведомление навсегда?

    
задан Mikko 03.11.2013 в 15:06
источник

1 ответ

2

Одно обходное решение, опубликованное на стартовой панели , - это сценарий, основанный на на крючках pm-utils:

sudo wget -O /etc/pm/sleep.d/20_kill-notify-osd https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1232454/+attachment/3942236/+files/20_kill-notify-osd
sudo chmod +x /etc/pm/sleep.d/20_kill-notify-osd

Другим способом решения может быть следующий метод:

Загрузите скрипт и сделайте его выполнимым:

wget -O ~/.suspendwarning.sh https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1232454/+attachment/3942095/+files/myscripts
chmod +x ~/.suspendwarning.sh

Добавьте его в ~/.bashrc :

echo "if [ -f ~/.suspendwarning.sh ]; then
. ~/.suspendwarning.sh
fi" >> ~/.bashrc

После выхода из системы и уведомления не должны появляться после возобновления.

    
ответ дан NadirHajiyev 23.02.2014 в 07:00