Звук наушников является односторонним в ubuntu 13.10

10

Я использую ubuntu 13.10 64bit. Я получил один односторонний звук (один канал) только в наушниках. Ноутбук громкоговоритель неплох. Разъем для наушников ноутбука и наушников хорошо работает. Это проблема с программным обеспечением. Я регулярно обновляю систему, и эта проблема происходит после последних 1 или 2 обновлений.

Также существует обходное решение. Установите уровень громкости на низкий и быстро установите его. После этого пару раз восстановите оба канала для наушников. Как решить эту проблему навсегда?

uname -r

3.11.0-15-generic

aplay -l

 **** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC270 Analog [ALC270 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

cat / proc / asound / version

Advanced Linux Sound Architecture Driver Version k3.11.0-15-generic.

head -n 1 / proc / asound / card * / codec # *

==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC270

==> /proc/asound/card0/codec#3 <==
Codec: Intel PantherPoint HDMI

pulseaudio --check [shows no output. with sudo return permission denied to read home directory]

pulseaudio --dump-conf

### Read from configuration file: /etc/pulse/daemon.conf ###
daemonize = no
fail = yes
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
allow-module-loading = yes
allow-exit = yes
use-pid-file = yes
system-instance = no
local-server-type = user
cpu-limit = no
enable-shm = yes
flat-volumes = no
lock-memory = no
exit-idle-time = 20
scache-idle-time = 20
dl-search-path = /usr/lib/pulse-4.0/modules
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = auto
log-level = notice
resample-method = speex-float-1
enable-remixing = yes
enable-lfe-remixing = no
default-sample-format = s16le
default-sample-rate = 44100
alternate-sample-rate = 48000
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 8
default-fragment-size-msec = 10
enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 1
deferred-volume-extra-delay-usec = 0
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 1000000

amixer -c 0

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 67 [77%] [-15.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [36.00dB]
  Front Right: 3 [100%] [36.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 18 [58%] [10.50dB] [on]
  Front Right: Capture 18 [58%] [10.50dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 [50%] [0.00dB]
  Front Right: Capture 60 [50%] [0.00dB]

pacmd dump-volume

No PulseAudio daemon running, or not running as session daemon.

sudo pactl info

Server String: unix:/run/user/1000/pulse/native
Library Protocol Version: 28
Server Protocol Version: 28
Is Local: yes
Client Index: 28
Tile Size: 65472
User Name: shantanu
Host Name: shantanu-voillo
Server Name: pulseaudio
Server Version: 4.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1b.0.analog-stereo
Default Source: alsa_input.pci-0000_00_1b.0.analog-stereo
Cookie: 381c:e256
    
задан shantanu 15.12.2013 в 09:00
источник

4 ответа

5

Попробуйте настройки в alsamixer - Откройте терминал и введите alsamixer :

Вы можете использовать д и со для регулировки левого и правого каналов.

    
ответ дан Wilf 17.12.2013 в 18:03
2

Если вы уже проверили соединения, и они хороши, и вы уверены, что это обновление вызвало эту проблему, эти ссылки могут помочь:

  1. Нет звука при подключении наушников .

  2. Вы можете обновить систему снова или попытаться очистить, а затем установить alsa-utils .

  3. Вы можете переключиться на загрузку с предыдущей версии ядра .

ответ дан precise 20.12.2013 в 12:08
0

начните с вершины. запустите приложение тестирования динамиков, чтобы выяснить, что происходит.

, если вы слышите звук с обеих динамиков ноутбука, переходите к вставке гнезда в разъем для наушников.

Если вы получаете звук от обоих громкоговорителей, но от одного наушника, проблема в разъемах (так как вы заявили, что вы уже проверили наушники на другом устройстве).

Если это так, возможно, может потребоваться какое-то давление на вставленное гнездо.

    
ответ дан nass 17.12.2013 в 18:17
0

Сначала ни один из моих аудиозаписей не работал. Затем я последовал инструкциям, чтобы заставить моих ораторов работать: Ссылка

Тем не менее, у меня не было звука для наушников. Затем я выполнил следующие инструкции:

Ссылка

Тогда работало только мое правое ухо.

Наконец, было установлено, что нужно открыть alsamixer и изменить loopback на disabled . В сущности я получил звук в обоих ушах.     

ответ дан max pleaner 06.01.2017 в 18:29