ошибка при загрузке разделяемых библиотек: libgtk-x11-2.0.so.0: Нет такого файла или каталога

10

Моя ОС - Ubuntu 14.04. Я пытаюсь загрузить версию Firefox 3.6.x. Я получил этот . Согласно README, все, что мне нужно сделать, это распаковать, ввести папку и запустить ./firefox . Однако при этом я получаю следующую ошибку:

./firefox-bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot 
open shared object file: No such file or directory.

Но когда я запускаю locate libgtk-x11 , он устанавливается:

/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0.2400.23

Кто-нибудь знает, где ищет ./firefox ? Я предполагаю, что мне нужно создать связь между папками, я просто не знаю, какой из них.

Изменить 1: после установки libgtk2.0-0:i386 и повторного запуска ./firefox , библиотеки libgobject-2.0 не найдены. Я пытаюсь установить их с sudo apt-get install libglib2.0:i368 , но я получаю:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libglib2.0-0-refdbg:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-dbg:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-0:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-dev:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-data:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-doc:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-cil:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-0-dbg:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-bin:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-cil-dev:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-tests:i386' for regex 'libglib2.0'
Note, selecting 'libglib2.0-data' instead of 'libglib2.0-data:i386'
Note, selecting 'libglib2.0-doc' instead of 'libglib2.0-doc:i386'
libglib2.0-data is already the newest version.
libglib2.0-doc is already the newest version.
libglib2.0-0:i386 is already the newest version.
libglib2.0-0:i386 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libglib2.0-cil:i386 : Depends: cli-common:i386 (>= 0.5.6) but it is not installable
                       Depends: libmono-corlib4.0-cil:i386 (>= 2.10.1) but it is not installable
                       Depends: libmono-system4.0-cil:i386 (>= 2.10.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

Возможно, libglib2 не является библиотекой, содержащей libgobject ?

    
задан regina_fallangi 12.10.2016 в 15:42
источник

2 ответа

19

Ваша система 64-разрядная, но поскольку вы хотите запустить 32-разрядную версию Firefox, вам необходимо установить 32-разрядную версию библиотеки:

sudo apt install libgtk2.0-0:i386
    
ответ дан fkraiem 12.10.2016 в 15:46
1

У меня была такая же проблема. Ответ @fkraiem заставил меня выяснить еще одну возможность, которая исправит мою проблему.

Я пытался запустить приложение в неправильной архитектуре. Поэтому убедитесь, что вы пытаетесь установить правильное приложение для своей системы 32 или 64 бита.

    
ответ дан gvsrepins 08.05.2017 в 18:14