Ошибка «Ошибка протокола 302» при установке VMware Player

10

Проблема

Для курса «Архитектура операционной системы» в Университете нам необходимо использовать VMware Player 3.1.4 для присвоений классов. В настоящее время я запускаю 64-разрядный Ubuntu 11.04 и недавно отформатирован с использованием ванильной установки 64-разрядной версии 11.04; который все еще имел следующий результат.

Я запускаю установку с помощью cd'ing в каталог, в котором находится пакет VMware и выполняется эта команда установки:

sudo sh ./VMware-Player-3.1.4-385536.x86_64.bundle

К сожалению, через половину секунды запуска скрипта установки я столкнулся с этой ошибкой:

  

./ VMware-Player-3.1.4-385536.x86_64.bundle: строка 302: /tmp/vmis.k6Yk9O/install/vmware-installer/vmware-installer: Permission denied

На котором извлеченный установщик выполняется по строке 302 со следующими параметрами:

302     "$installer" --set-setting vmware-installer libconf "$libconf"   \
303                  --install-component "$source"/vmware-installer      \
304                  --install-bundle "$bundle" "[email protected]"

Кроме того, md5sum, вызываемый в комплекте, возвращает точную сумму, указанную на странице загрузки.

  

a7fdadfb2af8d9f76571cd06f2439041 VMware-Player-3.1.4-385536.x86_64.bundle

На этом этапе я использовал sudo -i для входа в систему как root, который по-прежнему выбрал ошибку с разрешением.
Поиск Google и Stackoverflow предоставляется только еще один случай без ответов (я отмечен); поэтому я решил опубликовать в askubuntu вопрос, есть ли у кого-то одна проблема или есть исправление в 11.04?

Ура! : P     

задан Alex Stevens 06.08.2011 в 12:35
источник

1 ответ

7

Вероятно, установщик пытается выполнить двоичный файл в папке / tmp.

Вероятно, что в любом разделе, в котором находится ваша папка / tmp, он настроен в / etc / fstab как « поехес ». Это означает, что никакие двоичные файлы не могут быть выполнены на этом разделе.

Мой совет - переместить / tmp в свой собственный раздел, который имеет права «exec» в ваших параметрах строки fstab.

В качестве альтернативы временно измените «noexec» на «exec» в fstab - установите vmware и затем снова включите его.

    
ответ дан fossfreedom 07.08.2011 в 22:40
источник