Установите определенное разрешение экрана с помощью xrandr

10

Итак, я установил LUbuntu 11.04 на свой VirtualBox. Я не мог найти разрешение 1366x768, поэтому установил гостевые дополнения, но его там не было. Поэтому я использовал этот код для правильного разрешения:

gtf 1366 768 60
xrandr --newmode "1368x768_60.00"  85.86  1368 1440 1584 1800  768 769 772 795 $
xrandr --addmode VBOX0 1368x768_60.00
xrandr --output VBOX0 --mode 1368x768_60.00

Проблема в том, что я не могу найти способ сохранить эту информацию для следующей перезагрузки. Я пробовал .xinitrc , и ничего не происходит. Затем я попытался на .bashrc , но он не работает, мне нужно запустить консоль, прежде чем эти команды будут выполнены.

    
задан dierre 16.01.2012 в 16:13
источник

5 ответов

8

Я пытался изменить разрешение по умолчанию LXDE на Ubuntu (LXDE также используется в Lubuntu), и я нашел решение этой проблемы. У меня также установлен Lubuntu, и я проверил, что этот файл существует на самом деле (он просто испробовал это исправление, и он работал).

Итак, исправление ....

  1. Откройте терминал, нажмите ctrl + alt + t
  2. Я предполагаю, что у вас установлена установка по умолчанию Lubuntu, поэтому «Leafpad» будет вашим редактором по умолчанию, введите / скопируйте это в терминал и нажмите enter ... (вас может попросить ввести пароль)

    sudo leafpad /etc/xdg/lxsession/LXDE/autostart
    
  3. Теперь добавьте свои команды в конец файла, добавляя @ перед фактической командой. Моя выглядела так после ...

    @xscreensaver -no-splash
    @lxpanel --profile LXDE
    @pcmanfm --desktop --profile LXDE
    @/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
    @xrandr --auto --output DVI-1 --primary --mode 1680x1050 --left-of DVI-0
    
ответ дан captain_G 02.03.2012 в 22:58
источник
2

Я лично ставил такие команды, чтобы их запускать при входе в скрипт в ~/bin , назовите его set_resolution

Затем запустите gnome-session-properties и добавьте команду для запуска при входе в систему (используйте ~ / bin / set_resolution).

    
ответ дан Panther 17.01.2012 в 05:00
1

Вот еще одна строка, добавленная в мой файл /etc/xdg/lxsession/LXDE/autostart , чтобы заставить его работать:

@xrandr --output LVDS --off

отзыв от: Ссылка

Обновление: выше было отлично, пока я не запустил GUI-конфигурационный инструмент lxrandr , который кажется глупо не осведомленным о настройках с двумя мониторами. Поэтому я сделал это изменение:

$ cat $HOME/.config/autostart/lxrandr-autostart.desktop

[Desktop Entry]
Type=Application
Name=LXRandR autostart
Comment=Start xrandr with settings done in LXRandR --then manually tweaked
Exec=xrandr --output DVI-0 --mode 1920x1200 --rate 60.0 --output LVDS --off --output VGA-0 --primary --mode 1920x1200 --left-of DVI-0
OnlyShowIn=LXDE

Обратите внимание, что я запускаю Ubuntu 12.04 с LXDE. Можно было бы надеяться, что чистая настройка Lubuntu 12.04 будет включать более умный lxrandr двоичный файл ...

    
ответ дан MarkHu 25.09.2012 в 22:06
1

Эта страница помогла мне: Ссылка

Я закончил тем, что внес изменения в файл ~ / .xprofile

    
ответ дан rtconner 12.10.2013 в 09:16
0

Если кто-то все еще борется с этим, я пробовал все, что мог найти, не повезло (я поместил командную строку во множество файлов, которые я потерял). В конце концов, я нашел легкое решение путем проб и ошибок, и я попробовал бы его сначала перед всем остальным.

Откройте терминал и проверьте команду xrandr (как было опубликовано другими). Я использую Lubuntu на старой системе, чтобы дать ей немного больше жизни и установить старый монитор, чтобы моя линия cmd изменила разрешение.

xrandr --auto --output VGA1 --primary --mode 1158x864

не добавил никаких других вещей.

Затем пошли в start- > preferences- > Приложения по умолчанию для LXSession

Выбранное меню «автозапуск» затем поместите точный код командной строки в белое текстовое поле и нажмите «добавить».

Перезагрузка и успех !!!

    
ответ дан Russell Hepworth 17.09.2014 в 20:56