Как установить Adobe Acrobat Reader из репозитория?

56

Как установить Adobe Acrobat Reader в Ubuntu 14.04 с помощью репозитория Trusty apt ?

Это не дубликат Как установить пакет Adobe Acrobat Reader deb загружен с веб-сайта Adobe? . В Synaptic > Repositories > Other software я включил "Canonical Partners", но я до сих пор не могу установить acroread , поскольку он недоступен в моей 64-битной системе.

Вот результат с консоли:

[email protected]:/home/liv# apt-get install acroread
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package acroread
[email protected]:/home/liv# apt-get install acroread:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package acroread
    
задан landroni 25.04.2014 в 13:07
источник

8 ответов

66

Это немного более удобно для установки Adobe Acrobat Reader в Ubuntu 14.04, но это не сложно.

Откройте терминал.

Тип:

cd ~/Downloads && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb

Это загружает DEB-файл из Adobe и помещает его в папку «Загрузки». Следующий тип:

sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

Это установит Adobe Acrobat Reader.

Если вы используете 64-битную машину, вам может потребоваться добавить недостающие библиотеки, о которых упоминал Ним:

sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386

Если вы хотите использовать Acrobat Reader в качестве приложения по умолчанию для PDF-файлов, введите:

mimeopen -d *.pdf

Он отобразит список программ (для меня он отображается 3). Выберите номер, который имеет Acrobat Reader. Он откроет Acrobat Reader и скажет, что он не может открыть '* .pdf'. Игнорируйте эту ошибку и закройте Adobe Reader. Вы должны быть установлены сейчас.

    
ответ дан G Trawo 03.05.2014 в 13:46
25

Вместо того чтобы перечислять все зависимости явно, вы можете просто сделать это:

sudo apt-get install -f

Это автоматически исправит все неразрешенные зависимости.

Итак, вся последовательность команд должна быть такой:

cd ~/Downloads && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get install -f
    
ответ дан Undespairable 17.08.2014 в 23:32
4

Вы можете увидеть по ссылке: ubuntu-updates (см. раздел с исправлением), что пакет acroread еще не выпущен для 14.04 (верный).

Итак, дождитесь добавления в хранилища Canonical partners. В противном случае вы можете установить старую версию. См. аналогичный вопрос : Аналогичный вопрос для awn.

В этом случае я получаю ту же ошибку для awn: E: Unable to locate package avant-window-navigator

    
ответ дан Pandya 25.04.2014 в 13:26
4
  1. Загрузите Adobe Reader с сайта: Ссылка .

Выберите систему: Linux, ваш язык, Reader 9.5.5 для Linux (.deb)

  1. Установить gdebi:
sudo apt-get install gdebi
  1. Установите Adobe Reader через gdebi и примите зависимости:
sudo gdebi PACKAGENAME.deb
  1. Установить необходимые библиотеки:
sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386

Наконец, запустите Adobe Reader из контекстного меню меню, Dash или PDF.

через: ubuntuhandbook.org

    
ответ дан Nim 28.04.2014 в 12:17
1

по состоянию на 2014-10-23 ответ по-прежнему «вы не» (или не можете)

вряд ли когда-либо случится.

Последняя версия Acrobat reader для unix / linux - 9.5.5

Это сработало для меня (ответ от undespairable 17 августа не смог установить некоторые необходимые пакеты) на Xubuntu 14.04

# as root (prefix with sudo if you are running as an unprivileged user)
apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386
apt-get install --reinstall gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386
cd /tmp && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

после тестирования:

rm -rf /tmp/acroread_1000_1000
rm /tmp/AdbeRdr9.5.5-1_i386linux_enu.deb
    
ответ дан Derek Shaw 24.10.2014 в 22:49
0

Попробуйте использовать терминал:

sudo apt-get install acroread

и если не работает - используйте:

sudo apt-get install acroread:i386

Изменить: сначала используйте следующие команды:

sudo apt-add-repository multiverse
sudo apt-get update
    
ответ дан aastefanov 25.04.2014 в 13:12
0

Сегодня я успешно проверил следующее в новой установке kUbuntu 14.04.4 (официальный вкус Ubuntu).

Добавить Canonical PPA

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"

Обновить и установить

sudo aptitude update  
sudo aptitude install acroread  

Работает на kUbuntu 14.04 LTS
По состоянию на 30 апреля 2016 года, не работает над новым kUbuntu 16.04 LTS

    
ответ дан jtlindsey 19.02.2016 в 17:58
-1

Как я, наконец, установил Acrobat Reader на Ubuntu 14.04 на 64-битной машине:

  1. Я загрузил версию .deb с сайта adobe.com;

  2. Установите пакет, используя gedbi ;

  3. Установите библиотеки:

    sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386 
    

Готово!

    
ответ дан ionelf 04.05.2014 в 10:28