Искаженное и прерывистое аудио

10

После установки 12.04 Precise на моем ПК я столкнулся с некоторыми проблемами с аудиовыходом, которые не возникали при использовании Lucid.

Звук прерывистый и искаженный в нижних тонах. Поскольку у меня нет опыта в настройке / тестировании и что-либо делать с аудиоустройствами, мне нужна помощь даже для диагностики проблемы.

Update

$ sudo lshw -c multimedia

  *-multimedia  

       description: Audio device
       product: Radeon X1200 Series Audio Controller
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 5.2
       bus info: [email protected]:01:05.2
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=32
       resources: irq:19 memory:fdafc000-fdafffff
  *-multimedia
       description: Audio device
       product: SBx00 Azalia (Intel HDA)
       vendor: Hynix Semiconductor (Hyundai Electronics)
       physical id: 14.2
       bus info: [email protected]:00:14.2
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=snd_hda_intel latency=32
       resources: irq:16 memory:fe024000-fe027fff

Обновление 2

Это как-то связано с томом. Если звук тихий, он не прерывается, если звук громкий, тогда он начинает прерываться.

    
задан Misery 17.05.2012 в 08:13
источник

4 ответа

9

Misery, я, похоже, нашел решение в своей системе, используя один и тот же драйвер (хотя и с другим аудиоустройством)

  1. Открытый терминал: gksudo gedit /etc/modprobe.d/alsa-base.conf
  2. Добавьте следующую строку:

    options snd-hda-intel model=generic
    
  3. Перезагрузите систему

Теперь мой звук работает нормально. Полный объем, флэш-контент, видео, аудиофайлы. Сообщите нам, если это поможет.

Кредит отправляется Adityeah

    
ответ дан beanaroo 18.05.2012 в 10:20
источник
4

Возможное решение - отключить «автоматическое отключение звука» в alsamixer. Он используется, когда возникает ошибка «переключиться на наушники и обратно» (в основном в больших объемах).

Сначала откройте терминал или нажмите:

CTRL + ALT + T

Затем введите и нажмите «enter»:

$ alsamixer

Этот экран будет отображаться:

С помощью стрелки вправо выберите «Авто-отключение звука»

Затем нажмите стрелку вниз, чтобы установить его на «Отключить» (см. текст над ним).

Наконец, нажмите Esc для применения и выхода

Вот и все.

    
ответ дан Paulo Coghi 04.12.2013 в 20:43
1

Установите alsa-tools:

sudo apt install alsa-tools

Создайте и сохраните скрипт в / usr / local / bin:

sudo vi /usr/local/bin/sound_fix.sh

Внутри скрипта напишите:

#!/bin/bash
hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x67
hda-verb /dev/snd/hwC0D0 0x20 SET_PROC_COEF 0x3000

Запустите сценарий как root в терминале, чтобы немедленно устранить проблему.

Предоставить разрешение для запуска с использованием:

sudo chmod 700 [path_to_script_folder]/sound_fix.sh

Запустите сценарий, используя:

./[path_to_script_folder]/sound_fix.sh

Чтобы запустить сценарий при запуске, используйте cron с командой @reboot:

sudo crontab -e

, а затем добавьте строку в crontab:

@reboot [full_path_to_script_folder]/sound_fix.sh

Чтобы запустить сценарий при возобновлении с приостановки, скопируйте сценарий в

/lib/systemd/system-sleep

Подробнее об этом исправлении см. в этой ссылке.

    
ответ дан Shashank Dixena 19.07.2017 в 21:18
0

Для потрескивания шума в наушниках, особенно на левой стороне. напишите сценарий bash со следующими строками

hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x67
hda-verb /dev/snd/hwC0D0 0x20 SET_PROC_COEF 0x3000

Не забывайте выполнить как root.

И для систем, у которых нет hda-глагола, вы можете установить hda-глагол из соответствующих менеджеров пакетов

Добавьте сценарий к сценариям запуска или будет необходимость запуска скрипта каждый раз при загрузке системы

    
ответ дан saiteja c 20.01.2018 в 14:24