Как отключить звук во время изменения громкости в KDE / Kubuntu?

11

Я только что обновил Kubuntu с 12.04 по 14.04, и (как и ожидалось) есть несколько неприятностей. Первый, который я пробовал и не смог решить, - это «выскакивающий» звук, который воспроизводится всякий раз, когда я меняю громкость, с микшером или клавишами громкости. Мне достаточно с OSD, я не хочу звука.

У меня есть «no audio», выбранный в настройках уведомлений, но это не помогает.

Что-то еще я заметил и не помню, как это было раньше: когда отображается меню системного трея, клавиши громкости не работают ...

    
задан Jellby 24.05.2014 в 20:08
источник

3 ответа

9

Нажмите клавиши Alt + F2. Небольшое текстовое поле появится в верхней части экрана с несколькими значками. Введите kmix . И теперь у KMix будет свой логотип. Нажмите здесь. И посмотрите в области уведомлений, где должен быть громкоговоритель; нажмите на него. Вы получите диалоговое окно с несколькими кнопками. Выберите на нем кнопку с гаечным ключом. Откроется окно с именем «Настроить KMix». В этом окне слева появится опция General. В разделе «Общие» вы снимите флажок «Обратная связь с громкостью». закрыть окно. Щелкните правой кнопкой мыши на динамике в области уведомлений, выберите «Выход». И перезапустите KMix, как описано выше. Это должно решить вашу проблему.

    
ответ дан The Dentist 24.05.2014 в 20:46
источник
3

В то время как новые версии KDE4 (не говоря уже о Plasma5) имеют некоторые изменения в графическом интерфейсе настроек, другой способ - это опубликовать в этот .

Первое решение для KDE4 (System Settings > Common Appearance and Behavior > Application and System Notifications > Управление уведомлениями > Настройки проигрывателя & Отсутствует аудиовыход) не полностью сработало для меня.

Это может быть или не быть связано с этой ошибкой .

В любом случае, особенно для отключения звука, слышимого при изменении громкости : щелкните значок тома тома и отключите звуки событий:

    
ответ дан cipricus 29.01.2016 в 13:31
3

Проблема с GUI-ответом заключается в том, что им нельзя доверять слишком долго ...

Щелкните правой кнопкой мыши значок в трее:

Нажмите«Настройкигромкостизвука...Alt+D,S».

Отключить«Обратнаясвязьпотоку»(т.е.кнопкадолжнабытьсерой,анесиней).

Информация о версии:

~$ plasmashell --version
plasmashell 5.8.6
~$ kf5-config --version
Qt: 5.7.1
KDE Frameworks: 5.28.0
kf5-config: 1.0
    
ответ дан Clément 18.12.2017 в 17:51