Не удалось установить VLC и другие программы из-за странных проблем с зависимостями [duplicate]

10
The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but it is not going to be installed
       Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable
       Depends: libtar0 but it is not installable
       Depends: libva-x11-1 (> 1.3.0~) but 1.0.15-4 is to be installed
       Depends: libva1 (> 1.3.0~) but 1.0.15-4 is to be installed
       Depends: libvlccore7 (>= 2.1.0) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Я пробовал

  1. sudo apt-get install -f
  2. sudo apt-get update
  3. sudo apt-get upgrade
  4. sudo apt-get purge vlc vlc-nox libsdl-image1.2 libtar0 libva-x11-1 libva1 libvlccore7 vlc-plugin-notify vlc-plugin-pulse

Но ошибка остается. VLC - это не единственное. многие другие пакеты, которые я пытаюсь установить, дали мне похожие ошибки зависимостей, которые я, наконец, отказался от установки.

Я использую Ubuntu некоторое время. Я просто не понимаю, почему это происходит время от времени. Пожалуйста, помогите ...

EDIT:

Выход apt-cache policy vlc vlc-nox libsdl-image1.2 libtar0 libva-x11-1 libva1 libvlccore7

vlc:
  Installed: (none)
  Candidate: 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1
  Version table:
     2.1.4+git20150226+r54594+19+11~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ trusty/main i386 Packages
vlc-nox:
  Installed: (none)
  Candidate: 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1
  Version table:
     2.1.4+git20150226+r54594+19+11~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ trusty/main i386 Packages
libsdl-image1.2:
  Installed: (none)
  Candidate: (none)
  Version table:
libtar0:
  Installed: (none)
  Candidate: (none)
  Version table:
libva-x11-1:
  Installed: (none)
  Candidate: (none)
  Version table:
libva1:
  Installed: (none)
  Candidate: (none)
  Version table:
libvlccore7:
  Installed: (none)
  Candidate: 2.1.4+git20150226+r54594+19+11~ubuntu14.04.1
  Version table:
     2.1.4+git20150226+r54594+19+11~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/videolan/stable-daily/ubuntu/ trusty/main i386 Packages
    
задан user1224976 21.10.2015 в 18:16
источник

1 ответ

12

Как вы можете видеть в выводе apt-cache policy … , есть некоторые пакеты без кандидата на установку, и это не должно быть так. Поэтому быстрый поиск здесь показывает, что все пакеты доступны в репозитории юниверсов, например. для пакета libsdl-image1.2 .

Добавить репозиторий:

sudo apt-add-repository universe
sudo apt-get update
sudo apt-get install vlc
    
ответ дан A.B. 21.10.2015 в 18:36
источник