sudo apt-get из-за ошибки shared-mime-info.postinst

10

На моем сервере у меня возникает следующая проблема. sudo apt-get update работает успешно, но sudo apt-get upgrade завершается с ошибкой. Пожалуйста, помогите мне решить эту проблему.

[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  firefox linux-headers-server linux-image-server linux-server
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
21 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up shared-mime-info (0.71-1ubuntu2) ...
/var/lib/dpkg/info/shared-mime-info.postinst: line 13: 17650 Segmentation fault      update-mime-database.real /usr/share/mime
dpkg: error processing shared-mime-info (--configure):
 subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of libgtk2.0-0:
 libgtk2.0-0 depends on shared-mime-info; however:
  Package shared-mime-info is not configured yet.
dpkg: error processing libgtk2.0-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-browser:
 chromium-browser depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing chromium-browser (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-codecs-ffmpeg:
 chromium-codecs-ffmpeg depends on chromium-browser (>= 4.0.203.0~); however:
  Package chromium-browser is not configured yet.
dpkg: error processing chromium-codecs-ffmpeg (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-browser-l10n:
 chromium-browser-l10n depends on chromium-browser (= 16.0.912.77~r118311-0ubuntu0.10.04.1)No apport report written because the error message indicates its a followup error from a previous failure.
             No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                       No apport report written because MaxReports is reached already
                                                                                                                                                                                     No apport report written because MaxReports is reached already
                                                           No apport report written because MaxReports is reached already
                                                                                                                         No apport report written because MaxReports is reached already
                                                                                                                                                                                       No apport report written because MaxReports is reached already
                                                             No apport report written because MaxReports is reached already
                                                                                                                           No apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
                                                               No apport report written because MaxReports is reached already
                                                                                                                             No apport report written because MaxReports is reached already
   No apport report written because MaxReports is reached already
                                                                 ; however:
  Package chromium-browser is not configured yet.
dpkg: error processing chromium-browser-l10n (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libevdocument2:
 libevdocument2 depends on libgtk2.0-0 (>= 2.14.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libevdocument2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libevview2:
 libevview2 depends on libevdocument2 (>= 2.29.5); however:
  Package libevdocument2 is not configured yet.
 libevview2 depends on libgtk2.0-0 (>= 2.20.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libevview2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evince:
 evince depends on libevdocument2 (>= 2.29.5); however:
  Package libevdocument2 is not configured yet.
 evince depends on libevview2 (>= 2.29.5)No apport report written because MaxReports is reached already
                                                                                                       ; however:
  Package libevview2 is not configured yet.
 evince depends on libgtk2.0-0 (>= 2.16.0); however:
  Package libgtk2.0-0 is not configured yet.
 evince depends on shared-mime-info; however:
  Package shared-mime-info is not configured yet.
dpkg: error processing evince (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gcalctool:
 gcalctool depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing gcalctool (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgdict-1.0-6:
 libgdict-1.0-6 depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgdict-1.0-6 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-utils:
 gnome-utils depends on libgdict-1.0-6 (>= 2.23.90); however:
  Package libgdict-1.0-6 is not configured yet.
 gnome-utils depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing gnome-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gtk2-engines-pixbuf:
 gtk2-engines-pixbuf depends on gtk2.0-binver-2.10.0; however:
  Package gtk2.0-binver-2.10.0 is not installed.
  Package libgtk2.0-0 which provides gtk2.0-binver-2.10.0 is not configured yet.
 gtk2-engines-pixbuf depends on libgtk2.0-0 (= 2.20.1-0ubuntu2.1); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing gtk2-engines-pixbuf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgail18:
 libgail18 depends on libgtk2.0-0 (= 2.20.1-0ubuntu2.1); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgail18 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk2.0-bin:
 libgtk2.0-bin depends on libgtk2.0-0 (>= 2.20.1-0ubuntu2.1); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgtk2.0-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pidgin:
 pidgin depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing pidgin (--configure):
 dependency problems - leaving unconfigured
Setting up update-manager (1:0.134.11.1) ...
dpkg: error processing update-manager (--configure):
 subprocess installed post-installation script returned error exit status 245
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of update-notifier:
 update-notifier depends on libgtk2.0-0 (>= 2.14.0); however:
  Package libgtk2.0-0 is not configured yet.
 update-notifier depends on update-manager; however:
  Package update-manager is not configured yet.
dpkg: error processing update-notifier (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of xulrunner-1.9.2:
 xulrunner-1.9.2 depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing xulrunner-1.9.2 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of icedtea6-plugin:
 icedtea6-plugin depends on xulrunner-1.9.2; however:
  Package xulrunner-1.9.2 is not configured yet.
 icedtea6-plugin depends on libgtk2.0-0 (>= 2.8.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing icedtea6-plugin (--configure):
 dependency problems - leaving unconfigured
Setting up libgweather-common (2.30.0-0ubuntu1.1) ...
No apport report written because MaxReports is reached already
                                                              dpkg: error processing libgweather-common (--configure):
 subprocess installed post-installation script returned error exit status 245
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgweather1:
 libgweather1 depends on libgtk2.0-0 (>= 2.11.0); however:
  Package libgtk2.0-0 is not configured yet.
 libgweather1 depends on libgweather-common (>= 2.24.0); however:
  Package libgweather-common is not configured yet.
dpkg: error processing libgweather1 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 shared-mime-info
 libgtk2.0-0
 chromium-browser
 chromium-codecs-ffmpeg
 chromium-browser-l10n
 libevdocument2
 libevview2
 evince
 gcalctool
 libgdict-1.0-6
 gnome-utils
 gtk2-engines-pixbuf
 libgail18
 libgtk2.0-bin
 pidgin
 update-manager
 update-notifier
 xulrunner-1.9.2
 icedtea6-plugin
 libgweather-common
 libgweather1
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$ 

Спасибо, Avin

    
задан Avin Tokade 08.02.2012 в 09:22
источник

4 ответа

6

Если решение «dist-upgrade» не работает, попробуйте принудительно переустановить пакет shared-mime-info:

sudo apt-get update
sudo dpkg -P --force-all shared-mime-info
sudo apt-get install shared-mime-info
sudo apt-get -f install
sudo apt-get dist-upgrade
  • Если он снова не работает, мне нужен полный вывод вышеуказанных команд. Если он слишком большой, используйте Ссылка и поделитесь ссылкой здесь.
  • Мне также нужен вывод:

    apt-cache policy shared-mime-info
    sudo gdb update-mime-database.real -ex 'r /usr/share/mime'
    

Что-то подсказывает, что вы страдаете от этой ошибки: Ссылка

    
ответ дан Savvas Radevic 08.02.2012 в 09:42
3

Попробуйте сделать sudo apt-get update & amp; & amp; & amp; & amp; sudo apt-get dist-upgrade, если эта ошибка показывает, что все еще открываются синаптические > edit > исправлять сломанные пакеты, перезагружать и отмечать все обновления.

    
ответ дан bmbaker 08.02.2012 в 09:30
3

Эта проблема выглядит удивительно похожей на эту StackOverflow Question в том, что произошел сбой сегментации для того же пакета shared-mime-info

Решение было захоронено в комментариях до того, как его снова вернули в вопрос (!) - загрузите пакет maverick libxml2 и установите его перед запуском:

sudo apt-get update && sudo apt-get upgrade

Загрузите файл .deb , соответствующий вашей архитектуре (32bit - i386 и 64bt - amd64)

Установите пакет через синтаксис:

sudo dpkg -i [foo].deb

где [foo] - загруженное имя файла пакета.

например, используйте что-то вроде:

sudo dpkg -i libxml2_2.7.7.dfsg-4ubuntu0.3_i386.deb
    
ответ дан fossfreedom 13.02.2012 в 14:48
2

Я знаю, что это старо, но я получил ошибку, и я ее исправил. Я использовал Aptitude для этого.

Сначала перейдите и попросите Aptitude удалить как shared-mime-info , так и libxml2

sudo aptitude remove shared-mime-info libxml2

Затем Aptitude сообщит вам, что он удалит множество необходимых пакетов:

Accept this solution? [Y/n/q/?]

Ответ должен быть не n . Это даст вам другое решение

The following actions will resolve these dependencies:

 Install the following packages: 1)     shared-mime-info:i386 [1.0-0ubuntu4.1 (precise-updates)]

 Keep the following packages at their current version: 2)    libxml2 [2.7.8.dfsg-5.1ubuntu4.13 (now, precise-security, precise-updates)]

Accept this solution? [Y/n/q/?]

Для этого, скажем, да. Затем он установит правильную версию.

sudo apt-get update

sudo apt-get upgrade

Он отлично работал для меня. Удачи.

    
ответ дан Mohamed Alibi 21.12.2015 в 09:48