Не удается установить пакет ia32-lib

10

У меня есть несколько программ, которые требуют 32-битных пакетов (указывающих на пакет ia32-lib). Однако, когда я пытаюсь установить его, это происходит.

[email protected]:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch but it is not installable
E: Unable to correct problems, you have held broken packages.

Никакой большой крик, пакеты умирают все время. Однако я пробовал месяц спустя, но у меня все еще есть эта ошибка, и попытка установить конкретный пакет вызывает эту ошибку.

[email protected]:~$ sudo apt-get install ia32-libs-multiarch
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs-multiarch is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ia32-libs-multiarch' has no installation candidate

Я не Linux whiz-kid, но похоже, что пакет не существует. Я искал Skype в программном центре (мне сказали, что это устанавливает 32-разрядные пакеты), и он не появляется в программном центре, и загружаемый со своего веб-сайта вызывает ошибку - достаточно забавно - нет 32-битных пакетов.

Тот, кто помогает мне, получит медаль от богов с весом тысячи планет. Просто не надевайте его ради бога.

    
задан A British Person 19.11.2012 в 21:01
источник

6 ответов

12

Похоже, что установка через WUBI не правильно обнаруживала доступные внешние архитектуры. По мере того, как перекати-поле предлагалось печатать, зарубежные архитектуры, вероятно, ничего не возвращают. Добавьте i386 в качестве внешней архитектуры, обновите apt-кеш, затем установите 32-разрядные библиотеки.

sudo dpkg --add-architecture i386 && sudo apt-get update && sudo apt-get install ia32-libs
    
ответ дан Scotty Delicious 24.11.2012 в 03:44
источник
2

Ответ Скотти отлично подходит для 12.10, но если вы на 12.04, то dpkg не поддерживает --add-architecture . Просто попробуйте:

sudo apt-get update

, а затем попробуйте установить ia32-libs как

sudo apt-get install ia32-libs

Но, вероятно, лучше установить вместо этого мета-пакет ia32-libs-multiarch.

    
ответ дан Lakshman Kakkirala 14.03.2013 в 11:48
2
  • Установить Synaptic из окна терминала

    sudo apt-get install synaptic
    
  • Запустите настройки Synaptic и goto "> Хранилища»

  • Нажмите «другое программное обеспечение > добавить»
  • Вставьте эту строку в поле deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse
  • Нажмите ok и закройте Synaptic
  • В терминале sudo apt-get update
  • В терминале sudo apt-get install ia32-libs
  • Свежая установка
ответ дан Sîpan Roj 03.12.2013 в 19:39
0

Вы пытались установить их из программного обеспечения Ubuntu Software Center ? Он должен найти нас непосредственно в пакете, который мы ищем. Найдите «ia32», найдите ia32-libs-multiarch:i386 и ia32-libs и установите их.

Если это не решит проблему, попробуйте изменить сервер с Изменить > Источники программного обеспечения и запустите обновление от Диспетчера обновлений или sudo apt-get-update перед повторной установкой.

    
ответ дан Inoe 24.11.2012 в 06:36
0

Пакет ia32-libs недоступен, но упоминается другим пакетом! Ошибка установки

При установке офиса kingsoft я столкнулся с проблемой разрядной версии ОС (хорошо известная ошибка, но без правильного ответа) The following packages have unmet dependencies: ia32-libs: Depends: ia32-libs-multiarch but it is not installed . Я пробовал ~ 50 решений, но никто из них не работал. После этого я последовал за инструкцией терминала Ubuntu, и omg решил мою проблему.

Когда я уволил команду, я получил следующее сообщение:

Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32asound2 lib32z1 lib32ncurses5 lib32bz2-1.0

После этого я попытался установить все вышеупомянутые pkg один за другим и после установки «lib32z1» моя проблема была решена :)

sudo apt-get install lib32z1

sudo apt-get install lib32ncurses5

sudo apt-get install lib32bz2-1.0
    
ответ дан Hardik Thaker 23.04.2014 в 21:03
-1

Если у вас возникла эта проблема, скорее всего, вы находитесь на Precise 64-bit с Amazon EC2. Они исправили это для Ubuntu 12.10.

    
ответ дан Martin Konecny 03.05.2013 в 23:22