Не удалось найти пакет php7.0 [duplicate]

10

У меня есть ОС Ubuntu 14.04.2 LTS и пытаюсь установить PHP7 с помощью команды:

sudo apt-get install php-7.0

Получение сообщения об ошибке:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php-7.0
E: Couldn't find any package by regex 'php-7.0'

sudo apt-get install php7.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php7.0
E: Couldn't find any package by regex 'php7.0'

Как это исправить Пожалуйста, советую.

    
задан Ramesh Chand 02.01.2016 в 10:47
источник

1 ответ

34

PHP 7 недоступен для Ubuntu Trusty в стандартных репозиториях Ubuntu (2016-01-02).

Вы можете использовать PPA ppa:ondrej/php

sudo apt-add-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get install php7.0
    
ответ дан A.B. 02.01.2016 в 10:53
источник