add-apt-repository вызывает ошибку Python: UnicodeDecodeError: кодек ascii не может декодировать байты 0xc5

10

Попытка установить последние пакеты PHP5, и поэтому я добавляю репо ( sudo add-apt-repository ppa: ondrej / php5) Мне нужно, и это результат:

    Traceback (most recent call last):
  File "/usr/lib/python3.2/threading.py", line 740, in _bootstrap_inner
    self.run()
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 141, in run
    self.add_ppa_signing_key(self.ppa_path)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 234, in add_ppa_signing_key
    tmp_export_keyring, signing_key_fingerprint, tmp_keyring_dir):
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 186, in _verify_fingerprint
    got_fingerprints = self._get_fingerprints(keyring, keyring_dir)
  File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 178, in _get_fingerprints
    output = subprocess.check_output(cmd, universal_newlines=True)
  File "/usr/lib/python3.2/subprocess.py", line 516, in check_output
    output, unused_err = process.communicate()
  File "/usr/lib/python3.2/subprocess.py", line 811, in communicate
    stdout = _eintr_retry_call(self.stdout.read)
  File "/usr/lib/python3.2/subprocess.py", line 456, in _eintr_retry_call
    return func(*args)
  File "/usr/lib/python3.2/encodings/ascii.py", line 26, in decode
    return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 92: ordinal not in range(128)

Работает на сервере Ubuntu 12.04

    
задан James Heald 01.07.2014 в 17:44
источник

2 ответа

31

Общие свойства программного обеспечения являются ошибками, поэтому, если у вас есть время, сообщите об этом как об ошибке в программных свойствах-общих.

Лучшее обходное решение было указано в отслеживании проблем , в котором используется конкретный язык юникода при добавлении репозиторий

LC_ALL=C.UTF-8 add-apt-repository -y ppa:ondrej/php5-5.6
    
ответ дан oerdnj 02.07.2014 в 17:32
источник
1

Попробуйте установить языковой пакет, который может исправить ваши проблемы с кодировкой, например

sudo apt-get install language-pack-en

Это обеспечит обновление данных трансляции на английском языке для всех поддерживаемых пакетов (включая Python).

Смотрите: UnicodeEncodeError: кодек ascii не может кодировать символ .

В противном случае вручную задайте настройки локали, например

$ locale -a | grep "^en_.\+UTF-8"
en_GB.UTF-8
en_US.UTF-8
$ export LC_ALL=en_GB.UTF-8
$ export LANG=en_GB.UTF-8

Связано: ошибка локали с установкой apt-get

    
ответ дан kenorb 26.09.2017 в 12:25