Удалите пароль sudo при подключении к * новой * сети WiFi

10

В настоящее время, когда мой пользователь, не являющийся администратором, пытается подключиться к новой сети Wi-Fi (например, в кафе), NetworkManager запрашивает пароль администратора. Есть ли способ отключить это и позволить пользователю, не являющемуся администратором, подключиться к любой сети Wi-Fi, которая им нравится?

EDIT: просто для того, чтобы уточнить, я действительно имею в виду беспроводную сеть new , никогда не подключенную к компьютеру, поэтому нажатие «Доступно для всех пользователей» в существующем установленном соединении не решит проблему, так как в настоящее время нет проблем с повторным подключением не-администратора пользователя столько раз, сколько им нравится в домашней сети.

    
задан fpghost 18.01.2013 в 09:23
источник

4 ответа

10

Я нашел успех в следующем решении в Ubuntu 13.04:

Откройте /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy с правами root / sudo и выполните поиск следующей строки:

<message>System policy prevents modification of network settings for all users</message>

Несколько строк ниже этого должно быть следующим:

<allow_active>auth_admin_keep</allow_active>

Измените его на:

<allow_active>yes</allow_active>

Сохраните файл и перезагрузите компьютер.

    
ответ дан Kyle Spencer 03.07.2013 в 13:58
3

Вы также можете создать локальную политику для этого

[Let user pupil modify system settings for network]
Identity=unix-user:pupil
Action=org.freedesktop.NetworkManager.settings.modify.system
ResultAny=no
ResultInactive=no
ResultActive=yes

в файле с именем /etc/polkit-1/localauthority/50-local.d/10-network-manager.pkla .

Преимущество здесь в том, что это может быть одна команда и использоваться в скрипте!

printf "[Let user pupil modify system settings for network]\nIdentity=unix-user:pupil\nAction=org.freedesktop.NetworkManager.settings.modify.system\nResultAny=no\nResultInactive=no\nResultActive=yes" | sudo tee /etc/polkit-1/localauthority/50-local.d/10-network-manager.pkla

Ссылка: Ubuntu Manpage: pklocalauthority

    
ответ дан HarlemSquirrel 02.12.2015 в 18:11
3

Как разрешить ошибку: системная политика предотвращает изменение сетевых настроек для всех пользователей

В ответе выше есть критический шаг, поэтому я включаю его здесь. :)

Это работает в Ubuntu 14.04 LTS & amp; 16.04 LTS

  1. Откройте Terminal

  2. su до root

    su -
    
  3. Введите следующее:

    nano /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy
    
  4. В конце файла найдите раздел с надписью:

    <action id="org.freedesktop.NetworkManager.settings.modify.system">
    
  5. В нижней части раздела org.freedesktop.NetworkManager.settings.modify.system найдите следующую строку кода:

    <allow_active>auth_admin_keep</allow_active>
    
  6. Измените эту строку следующим образом:

    <allow_active>yes</allow_active>
    
  7. Сохраните файл, используя:

    ^X
    
  8. Ответ "Сохранить измененный буфер (ОТВЕТ" Нет "ИЗМЕНИТЬ ИЗМЕНЕНИЯ)?" Ввод :

    Y
    
  9. Нажмите Enter , когда будет предложено:

    File Name to Write: /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy
    
  10. <р> Перезагрузка .

:)     

ответ дан bu11etpr00f 01.12.2016 в 20:17
2

На самом деле это не то исправление, на которое я надеялся, но одно обходное решение, которое я нашел, - это просто отключить NetworkManager all-together и вместо этого использовать Wicd .

Первая остановка NetworkManager от запуска при запуске:

sudo gedit /etc/NetworkManager/NetworkManager.conf

, затем # из строки managed . Также # out #start on (local-filesystems and started dbus) из /etc/init/network-manager.conf . Затем просто чтобы сделать двойной уверен

sudo mv /etc/init/network-manager.conf /etc/init/network-manager.conf-disabled
sudo mv /etc/xdg/autostart/nm-applet.desktop /etc/xdg/autostart /nm-applet.desktop.disabled  

Теперь вы можете просто использовать Wicd , и никаких запросов пароля не требуется.

    
ответ дан fpghost 18.01.2013 в 19:48