Рабочий стол не отображается, когда я устанавливал драйверы nvidia!

69

Рабочий стол не отображается после установки драйверов nvidia. Я пробовал nvidia простыми проприетарными драйверами, и они тоже не работали.

Вот как это выглядит. Это не обрезается или что-то еще. Вот как это выглядит, после установки драйверов разрешение рабочего стола уменьшилось с 1440x900 до 1024x768.

На рабочем столе отображаются только деск и панели, когда я использую драйверы с открытым исходным кодом.

Есть ли способ исправить это, чтобы я мог повысить производительность?

    
задан Levan 18.10.2012 в 19:59
источник

10 ответов

79

У меня было то же самое. Вот как я его исправил:

  1. Переключитесь на терминал Ctrl + Alt + F1 .

  2. Войдите как свое имя пользователя.

  3. Установите заголовки linux:

    sudo apt-get install linux-headers-generic
    
  4. Удалите драйвер nvidia - это зависит от того, какая версия была установлена:

    sudo apt-get remove nvidia-current
    

    или

    sudo apt-get remove nvidia-current-updates 
    

    или

    sudo apt-get remove nvidia-experimental-304
    
  5. Переустановите драйвер nvidia

    sudo apt-get install nvidia-current-updates
    

    Когда вы это сделаете, он должен сказать что-то вроде:

    Building initial module for 3.5.0-17-generic
    Done.
    

    Если он говорит

    Module build for the currently running kernel was
    skipped since the kernel source for this kernel
    does not seem to be installed.
    

    , тогда проблема не будет решена. Не верьте сообщению. Он не запрашивает linux-source для установки, он хочет только заголовки, но вы должны установить определенные заголовки -generic для ваше ядро. Run:

    sudo apt-get install linux-headers-'uname -r'
    

    Он будет не работать только с linux-headers-generic или linux-headers-3.5.0-17 (например).

  6. Если он успешно установит, перезагрузите компьютер:

    sudo shutdown -r now
    

Это должно позволить модулю ядра правильно компилироваться и устанавливать. Это было для меня!

    
ответ дан rft183 18.10.2012 в 20:39
источник
9

Если рабочий стол по-прежнему не отображается, это может быть связано с графической картой Nvidia Optimus . У меня есть ноутбук с GT 650M , и это также карта Optimus. Карты Optimus ведут себя по-другому, и по умолчанию для них нет поддержки Linux. Дополнительная информация о Optimus в linux: Ссылка

Но можно заставить его работать с Bumblebee . Так я сделал это на новой установке Ubuntu 12.10 (нет драйверов nvidia):

sudo add-apt-repository ppa:bumblebee/stable 
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic 

Затем перезагрузитесь или перейдите в систему.

Это не сработало, когда я прекратил эту вторую команду. Затем для запуска чего-то с графическим типом карты optirun перед командой. В примере: optirun glxspheres или optirun ./executable-file . Хороший способ проверить разницу между встроенной графикой и графической картой - запустить glxspheres с помощью и без optirun .

Ссылка

Это экономит электроэнергию при активации графической карты только тогда, когда это необходимо. Надеюсь, я помог кому-то, потому что я потратил часы, чтобы узнать проблему с моей графической картой (да, я совершенно новый с этими графическими драйверами Linux).

    
ответ дан Arttu 04.12.2012 в 15:18
5

После вмешательства в это несколько вечеров (исчезновение единственного рабочего стола, только разрешение 640x480, странные артефакты на моем экране) на моем GeForce GT 630, это то, что сработало для меня:

  1. Новая версия Ubuntu 12.10
  2. Сразу после установки запустите программу обновления программного обеспечения. Загрузить & amp; Установка всех обновлений
  3. Reboot
  4. sudo apt-get install linux-sources && sudo apt-get install linux-headers-generic (я не совсем уверен, нужен ли мне этот шаг, но я видел его в этом потоке и думал, что попробую)
  5. Откройте «Источники программного обеспечения» из Dash
  6. Перейдите на вкладку «Дополнительные драйверы».
  7. Активировать драйвер xinary xorg NVIDIA (проприетарный, проверенный)
  8. Reboot

пока что так хорошо - у меня есть панель настроек NVIDIA (без сообщения об ошибке Xconfig), двух мониторов и высокого разрешения.

Особое примечание: НЕ устанавливайте пакет дополнительных драйверов (Jockey). Этот пакет фактически исчезает после шага 2 (обновления программного обеспечения) - метод добавления дополнительных драйверов, похоже, переместился в приложение «источники программного обеспечения».

    
ответ дан Jim Keller 22.11.2012 в 03:00
3

Я только что установил Ubuntu 12.10 сегодня и имел эту проблему с драйвером nvidia.

Я попытался выполнить приведенные выше инструкции, но все это не удалось из-за двух важных слов: «generic» и «-17».

В итоге я обнаружил, что лучший способ установки драйвера NVidia - фактически использовать установщик, выделенный nvidia. Поэтому я пошел:

Ссылка

и загруженная версия для Linux-64bit (установить synaptic sudo apt-get install synaptic и посмотреть в меню «Настройки - > Репозиторий - > Дополнительные драйверы, чтобы узнать точное имя вашей карты nvidia»)

Затем вы запустите инструмент, и он говорит, что вам нужны заголовки ядра, однако внимательно их читайте, потому что для этого требуются «общие» заголовки.

Вам нужно проверить версию ядра, мой был 3.5.0-17 (этот вопрос «-17» в конце концов), поэтому в моем случае я сделал:

sudo apt-get install linux-headers-3.5.0-17-generic

(узнайте свою версию ядра, набрав ina terminal uname -r )

Вам нужно убить GUI login daemon:

killall lightdm

и после этого вы можете запустить:

sudo sh NVIDIA-Linux-x86_64-310.19.run

Установщик, вероятно, скажет вам, что модуль ядра Noveau загружен и предложит добавить скрипт modprobe. Вы должны сказать «ОК / Да» всем, что он вам скажет, а затем перезагрузите и снова запустите NVIDIA-Linux-x86_64-310.19.run.

Не уверен, что другой подход будет работать, но это точно.

    
ответ дан Radek 21.12.2012 в 13:14
2

Это также работает для карт Nvidia 7400. Но если обновление ядра, вы должны изменить линию установки на последнюю версию, это:

sudo apt-get install linux-headers-3.5.0-18-generic

вместо этого:

sudo apt-get install linux-headers-3.5.0-17-generic
    
ответ дан Daniel Zippert 20.10.2012 в 19:19
0
sudo apt-get install nvidia-current nvidia-settings
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
sudo nvidia-xconfig

Перезагрузите систему!

    
ответ дан BlitzkriegBop 19.10.2012 в 18:08
0

Я пробовал почти все, но вот тот, который действительно работал для меня:

выполните следующие команды:

sudo add-apt-repository ppa:amith/ubuntutools
sudo apt-get update
sudo apt-get install unity-reset

, затем сбросьте единицу с помощью этой команды:

unity-reset

reboot и Unity возвращается! Надеюсь, это сработает для вас.

    
ответ дан camilo garcia 12.11.2012 в 00:27
0

Я решил проблему сегодня. Я установил последний Kernel 3.7.1 после компиляции, как и всегда. Затем я установил драйверы nVidia из Synaptic. Это заставило меню Unity исчезнуть, как показано на скриншоте. Решение для меня ниже:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Теперь не только проблема, которую вы решаете, у вас есть самые последние драйверы nVidia!

    
ответ дан Joel Frese 09.01.2013 в 05:16
0

Если ваша установка не работает (исходный модуль не создается), вы должны убедиться, что у вас установлен только один набор заголовков.

dpkg --get-selections | grep linux-headers

Это не работает

linux-headers-3.5.0-26              install
linux-headers-3.5.0-26-generic      install
linux-headers-generic               install

Это работает

linux-headers-3.5.0-26              install
linux-headers-3.5.0-26-generic      install

В этом случае просто

apt-get remove linux-headers-generic

Теперь установщик nvidia будет работать.

    
ответ дан Nate Symer 07.04.2013 в 04:02
-1

Я сделал это:

sudo apt-get autoremove fglrx --purge

Работал отлично.

    
ответ дан Shaun 06.12.2012 в 05:10