Очень медленные, прерывистые скорости WiFi с 14.04 и Intel PRO / Wireless 5100 AGN [Shiloh]

10

Я сделал новую установку Ubuntu 14.04 LTS на жестком диске ноутбука Lenovo Y650 Ideapad. Беспроводным адаптером является Intel PRO / Wireless 5100 AGN [Shiloh].

Первоначально я не мог подключиться к каким-либо беспроводным сетям; однако я мог их видеть. При подключении через Ethernet нет проблем. Мне удалось подключиться к беспроводной сети, введя эту команду в терминале:

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

Скорости очень медленные и прерывистые. Когда я могу запустить тест скорости, пинг хорош (от 24 до 26 мс), но скорость загрузки колеблется от 0,15 до 0,30 Мбит / с.

iwconfig

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"PinkRabbit"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: E8:40:F2:CD:18:0B   
          Bit Rate=2 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-26 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:254   Missed beacon:0

Ifconfig

eth0      Link encap:Ethernet  HWaddr 00:23:5a:d2:70:91  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:171 errors:0 dropped:0 overruns:0 frame:0
          TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:15613 (15.6 KB)  TX bytes:15613 (15.6 KB)

wlan0     Link encap:Ethernet  HWaddr 00:1e:65:3e:0c:48  
          inet addr:192.168.0.13  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21e:65ff:fe3e:c48/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:42 errors:0 dropped:0 overruns:0 frame:0
          TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9032 (9.0 KB)  TX bytes:16851 (16.8 KB)

нм инструмент

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            tg3
  State:             unavailable
  Default:           no
  HW Address:        00:23:5A:D2:70:91

Capabilities:
    Carrier Detect:  yes

Wired Properties
    Carrier:         off

- Device: wlan0  [PinkRabbit] --------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        00:1E:65:3E:0C:48

  Capabilities:
    Speed:           1 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *PinkRabbit:     Infra, E8:40:F2:CD:18:0B, Freq 2412 MHz, Rate 54 Mb/s, Strength       92 WPA WPA2

  IPv4 Settings:
    Address:         192.168.0.13
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             64.71.255.204
    DNS:             64.71.255.198
    DNS:             8.8.8.8
    DNS:             8.8.4.4
    
задан user3232837 29.04.2014 в 23:56
источник

6 ответов

11

Я не знаю, насколько это актуально, но новичок в Ubuntu, но у меня были проблемы с моей картой Ralink 5362.

Единственное, что казалось ему полезным, это следующее:

В Ubuntu есть ошибка в Debian Avahi daemon. Чтобы решить эту проблему, необходимо отредактировать следующий файл /etc/nsswitch.conf следующим образом.

Введите в командной строке следующее

sudo -H gedit  /etc/nsswitch.conf

Это откроет файл nsswitch.conf в текстовом редакторе. Затем просто измените следующую строку

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

в строку ниже и сохраните файл.

hosts:          files dns

Сбросьте подключение к Интернету или, возможно, перезапустите систему, и ваше беспроводное соединение должно вернуться на максимальную скорость. Это работало для меня как минимум.

    
ответ дан Yannis Pasvantis 02.02.2015 в 12:20
4

На самом деле у меня тоже есть эта проблема, поэтому я с нетерпением жду любого постоянного решения, но одно временное:

sudo iwconfig wlan0 rate 54M

, где 54M - это ваша фактическая беспроводная возможность.

    
ответ дан k0ryfi 11.05.2014 в 22:02
1

Я заметил ту же проблему с моим ноутбуком (Intel Wireless 7260 / Lenovo W540). Каждые несколько дней сеть замедляется до обхода (включает трафик по всем протоколам: http, ssh, ftp и т. Д.). Я считаю, что я тоже испытал такое же поведение над eth0, но не могу вспомнить.

Обходной путь для меня - перезапуск сетевого менеджера, который, похоже, устраняет любые проблемы.

[email protected]:~$ sudo service network-manager restart

lshw

[email protected]:~$ sudo lshw -C network
  *-network               
       description: Ethernet interface
       product: Ethernet Connection I217-LM
       vendor: Intel Corporation
       physical id: 19
       bus info: [email protected]:00:19.0
       logical name: eth0
       version: 04
       serial: 3c:97:0e:ea:1b:a4
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:44 memory:b2a00000-b2a1ffff memory:b2a3f000-b2a3ffff ioport:5080(size=32)
  *-network
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: [email protected]:03:00.0
       logical name: wlan0
       version: 6b
       serial: 7c:7a:91:06:7b:e2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-29-generic firmware=22.1.7.0 ip=192.168.1.158 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:45 memory:b2800000-b2801fff
    
ответ дан Justin 12.06.2014 в 16:11
1

Я могу предложить вам установить Kernel 3.13.0-37_3.13.0-37.64 + iwlltr0001 из: Ссылка

и прошивку Intel iwlwifi-3160-9-ucode.

После этого я набрал терминал:

  

$echo "options iwlmvm power_scheme=1" | sudo tee /etc/modprobe.d/iwlmvm.conf
$echo "options iwlwifi bt_coex_active=Y swcrypto=1 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
$sudo reboot

    
ответ дан ai20 26.10.2014 в 01:24
1
  1. Откройте «Дополнительные драйверы»
  2. Перейдите на вкладку «Другое программное обеспечение», отметьте все поля
  3. Обновить драйвер
ответ дан imeckr 16.12.2014 в 18:44
-1

Попробуйте отключить IPv6: Перейдите к редактированию сетевых подключений, выберите свое соединение, перейдите на вкладку IPv6, измените его, чтобы игнорировать.     

ответ дан James 28.12.2014 в 09:20