Установка Teamviewer ubuntu 12.04

1

Я загружаю данный пакет teamviewer для Ubuntu с официального сайта и загружаю обе ссылки. 1.teamviewer_amd64.deb (Здесь ошибка не установлена ​​i386)
2.teamviewer_i386.deb (Согласно их сайту, это на самом деле то, что мне нужно).

Итак, когда я устанавливаю (2.) через программный центр ubuntu, я обнаружил ошибки.

Selecting previously unselected package teamviewer:i386.

(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%   
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 163057 files and directories currently installed.)
Unpacking teamviewer:i386 (from .../Desktop/teamviewer_i386.deb) ...
dpkg: dependency problems prevent configuration of teamviewer:i386:
teamviewer:i386 depends on libfontconfig1.
dpkg: error processing teamviewer:i386 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
teamviewer:i386

Поэтому я запускаю команду sudo apt-get install -f , а затем выполняю команду sudo apt-get install libfontconfig1 , и, делая это, я получил этот

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libfontconfig1 is already the newest version.
The following packages were automatically installed and are no longer  required:
mingw-w64 sbsigntool libxfixes3:i386 gir1.2-timezonemap-1.0 realpath
efibootmgr diffstat libdmraid1.0.0.rc16 libdebconfclient0
binutils-mingw-w64-i686 kpartx-boot libopts25 gir1.2-json-1.0 quilt   autogen
libfreetype6:i386 gcc-mingw-w64 user-setup libexpat1:i386 gcc-mingw-w64-i686
kpartx rdate libxcb1:i386 libxau6:i386 binutils-mingw-w64-x86-64
libxinerama1:i386 libdebian-installer4 libopts25-dev libice6:i386
libxdmcp6:i386 btrfs-tools apt-clone localechooser-data libasound2:i386
gcc-mingw-w64-base libxrender1:i386 libjpeg62:i386 libxtst6:i386
gcc-mingw-w64-x86-64 libx11-6:i386 libsm6:i386 archdetect-deb
libxdamage1:i386 dmraid python-pyicu mingw-w64-dev libxext6:i386
libxrandr2:i386 gir1.2-xkl-1.0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 534 not upgraded.

Я, чем снова установил, что teamviewer_i386.deb , и снова получаю ту же самую ошибку о libfontconfig1 , которая не устанавливается, которую я вставлял ранее.

Пожалуйста, помогите, что происходит. Даже я также пытался установить языковые пакеты, но не работал. Даже если при попытке установить как синаптический пакет, он сначала отображает teamviewer_i386.deb .

Итак, как установить Teamviewer в Ubuntu 12.04 64bit.

Спасибо заранее ...

    
задан Nikhil Kumar 30.06.2015 в 05:25
источник

3 ответа

1
  

Итак, как установить Teamviewer в ubuntu 12.04 64bit.

Итак, ваша система 64-разрядная.

  

Итак, когда я устанавливаю (2.) через программный центр ubuntu, я получил ошибку   шоу

Итак, вы устанавливаете 32-битную версию?!

Почему вы это делаете, поскольку у вас есть 64-битный пакет, почему вы собираетесь установить 32-битный пакет.

В любом случае

teamviewer:i386 depends on libfontconfig1.

Затем вы должны установить libfontconfig1: i386, а не только libfontconfig1, но это может привести вас к некоторым зависимым адам.

Поэтому я советую вам снова загрузить 64-битную версию и установить ее, чтобы избавиться от этих возможных проблем.

Цитата из: Как сделать Я устанавливаю TeamViewer в свой дистрибутив Linux?

Для 64-разрядных DEB-систем без Multiarch вам необходимо teamviewer_amd64.deb .

Для 64-разрядного пакета:

sudo dpkg -i teamviewer_linux_x64.deb

В случае, если «dpkg» указывает на отсутствующие зависимости, выполните установку, выполнив следующую команду:

sudo apt-get install -f
    
ответ дан Maythux 30.06.2015 в 07:53
0

Как я уже писал в другом месте.

Вы можете попробовать сделать это sudo apt-get purge team-viewer-package-name и sudo apt-get purge libfontconfig1 , а затем установить libfontconfig1 , а затем Teamviewer .

Purge - Очистка идентична удалению, за исключением того, что пакеты удаляются и удаляются. Очистка означает, что любые файлы конфигурации также удаляются.

Также попробуйте это и посмотрите, какие у всех каталогов установлены в них teamviewer dpkg -L team-viewer-package-name и dpkg -L libfontconfig1 .

Убедитесь, что вы запустили это после установки libfontconfig1 sudo apt-get update и sudo apt-get upgrade .

Сообщите мне, если это работает или нет.

    
ответ дан SamFlynn 30.06.2015 в 05:46
0

Введите эти команды после получения сообщения об ошибке

dpkg --add-architecture i386
apt-get update

Это указано в teamviewer , что существует вероятность ошибочной ошибки архитектуры при установке пакета x86 на 64 бит. Это должно решить проблему.

    
ответ дан Trinadh venna 30.06.2015 в 05:50