Где я могу найти пакеты Vagrant?

10

Vagrant - это инструмент для создания и управления виртуальными машинами для разработчиков. Он содержит начало работы в руководстве Ubuntu , в котором содержатся предложения iffy-look, такие как

$ sudo ln -s /usr/bin/ruby1.8 /usr/bin/ruby  # wtf???

или установки RubyGems из источника, а не из пакетов Ubuntu, а затем с помощью gem install для установки самого бродяга.

Я не чувствую себя комфортно, следуя этим инструкциям. Возможно ли PPA? Есть ли, возможно, альтернативные инструменты, которые упакованы для Ubuntu?

    
задан Marius Gedminas 06.11.2010 в 15:09
источник

4 ответа

9

12.04

Бродяга 1.0.1 теперь включен в юниверс в 12.04, и вы можете установить его через Центр программного обеспечения.

    
ответ дан ajmitch 21.03.2012 в 03:27
источник
16

В настоящее время вы можете загружать автономные файлы .deb из Ссылка

Не так хорошо, как PPA, но, по крайней мере, вы можете понять, какие файлы устанавливаются там и удалять пакет.

    
ответ дан Marius Gedminas 11.03.2012 в 17:18
-2

Нечего беспокоиться о инструкциях в этом запуске в руководстве Ubuntu . Создание софт-ссылки в /usr/bin/ruby1.8 не повредит вашей системе. Просто продолжайте обучение и установите vagrant. Чтобы установить бродягу, вы можете использовать:

  sudo gem install vagrant

Насколько я знаю, для бродяг нет PPA. Лучший способ его установки - использовать драгоценный камень.

Если вы испытываете какие-либо трудности, не стесняйтесь публиковать его здесь.

    
ответ дан aneeshep 08.11.2010 в 05:12
-2

Если вы используете Ruby:

Лучше установить его через Rubygems, несмотря на рекомендацию веб-сайта по установке .deb. Веб-сайт, похоже, немного отстает от обновлений. Инструкции бродячего драгоценного камня выглядят более современными: Ссылка

Если Bundler устанавливает версию 1.0.0 для версии gem:

  • поставьте gem 'vagrant' над всеми другими драгоценными камнями в Gemfile и запустите bundle install .
  • Если это все еще не работает, поставьте gem 'vagrant', '~> 1.0' и запустите bundle install .

Иногда bundler устанавливает старую версию vagrant gem, если ваши другие драгоценные камни устанавливают старые версии драгоценных камней, например json .

    
ответ дан dgo.a 12.03.2012 в 13:37