Видеоролики имеют голубые лица, когда я их играю

10

Я начал видео, и он говорит, что у него нет кода и он может его искать (он выглядел круто), и он загрузил их, и видео отлично работает, но почему-то все лица на видео, которые я смотрю, являются синими , как сделать их не синими? (Уверен, что это общая проблема).

P.S. Я не предвзято отношусь к инопланетянам, мне они просто не нравятся.

    
задан UAdapter 06.01.2011 в 16:52
источник

9 ответов

4

Я запускаю 12.04 LTS с Nvidea GeForce 8400M GS (512 МБ). SMPlayer (версия 0.81) - мое приложение для воспроизведения по умолчанию. & Амп; Totem Movie Player 3.0.1 (Movie Player с помощью GStreamer 0.10.36)

Все фильмы, открытые с hdd, показывают «синие лица». Однако иногда при открытии «Nvidea XServer Settings» следующее видео, которое я воспроизвожу, имеет нормальные цвета. (только один раз ... открытие того же фильма снова покажет синие лица)

ИСПРАВЛЕНИЕ:

Загрузите и установите приложение «Sysinfo». и откройте его. Выберите «Nvidea» - «Настройки отображения Nvidea». В разделе «X Screen 0» выберите «X Server Xvideo Settings». Сдвиньте регулятор «Hue» до нуля.

Если это не помогло (в моем случае нет возможности сохранить этот параметр, но только опция «выйти из настроек Nvidea XServer»), откройте «Totem Movie Player»,

Откройте видео и проверьте «синие лица». Пусть видео продолжит воспроизведение. Перейдите к «edit», «Preferences», «Display»: сдвиньте контроллер «Hue» до нуля. Пока вы сдвигаете Hue вниз, вы увидите, что цвета меняются в обычном режиме.

В моем случае изменения, сделанные в Totem Movie Player, которые также адаптированы в SMPlayer и все видео, теперь воспроизводятся в обычных цветах.

    
ответ дан Roger 27.09.2012 в 00:30
источник
6

В сообщении об ошибке, что ссылки Clausi существуют довольно много обходных решений.

Этот совет от Le Glun de net выглядит как лучший aproach для меня.

If you have this bug (blue and red color in video are invert) and you have a nvidia, you don't have to install or uninstall any software. Just launch the "nvidia X server settings", choose your screen (X screen 0), "Xserver video settings", "Reset hardware defaults".

Обратите внимание, что он, кажется, исправляет себя, как только вы открываете настройку Nvidia для некоторых людей.

    
ответ дан Javier Rivera 18.01.2011 в 08:01
4

у этого, кажется, есть несколько различных возможных причин.

Скорее всего, вы можете исправить это, просто используя другой метод вывода в mplayer. попробуйте:

mplayer -vo xv movie.avi

или

mplayer -vo gl movie.avi

Существуют аналогичные флаги для других игроков, таких как vlc, и я уверен, что он также находится на странице настроек вашего любимого графического интерфейса. (Я знаю, что это в vlc и smplayer по крайней мере)

    
ответ дан scottl 18.01.2011 в 07:46
4

"1. Откройте свойства gstreamer (alt + f2, введите свойства gstreamer)

  1. Перейдите на вкладку видео

  2. Измените плагин вывода по умолчанию на «custom»

  3. В нижнем поле введите следующую команду: videobalance hue = -1! autovideosink

  4. Закройте окно и наслаждайтесь цветом теперь

ответ дан Lincity 22.01.2011 в 09:37
3

От Ссылка :

  1. открыть тотем через приложения > Звук & amp; Видео > Movie Player
  2. откройте окно настроек через Edit > Предпочтения
  3. выберите вкладку «Экран»
  4. нажмите кнопку «Сброс к умолчанию»
ответ дан Clausi 06.01.2011 в 22:18
2

Создайте файл /etc/adobe/mms.cfg , если он не существует

Добавьте строки или измените значения:

EnableLinuxHWVideoDecode=1
OverrideGPUValidation=true

Решение от: Ссылка

    
ответ дан Abhinav 09.04.2012 в 23:32
2

Для меня это то, что выход видео я установил Directx (прямой ничья). Я изменил его на Open GL, и он исчез. Кажется, что Direct Draw действительно нарисовать шкуры синим цветом. Прикольно смешные люди реальной жизни. Im использовал Vlc-плеер и имел много проблем. Включил Gpu для отставания и аппаратного ускорения. Видеокодек для Open Gl. Все еще не работает хорошо, но лица больше не синие, и лучше всего я могу понять.

    
ответ дан Siggie 19.08.2013 в 21:54
0

Помимо остальных предложений, за которыми я последую, если все не удастся, попробуйте установить последние драйверы nvidia (если вы их используете)

    
ответ дан luri 21.01.2011 в 11:55
0

Вы пробовали другой медиаплеер? какой из них вы используете?

Я попытался бы воспроизвести видео в VLC ?

 sudo apt-get install vlc

или mplayer

    
ответ дан Luciano Facchinelli 17.01.2011 в 03:55