Обмен не обнаружен на 14.04 LTS

12

Я обновился с 12.04 по 14.04. Когда я открыл монитор ресурсов, я заметил, что мой обмен не был обнаружен. Я установил Gparted, открыл программу и начал смотреть на мое дерево файлов. Я заметил, что моя область подкачки была отмечена как unknown , рядом с ней был красный восклицательный знак. Я отформатировал его как linux-swap, а затем выбрал «swapon» из меню. Я перезагрузил системный монитор, и казалось, что моя проблема решена.

Я перезапустил свой компьютер, снова открыл системный монитор, и я увидел, что свопа больше нет. В Gparted на этот раз раздел был распознан как своп, но система его не увидела. Мне нужно «swapon» каждый раз, когда моя система перезагружается.

Я впервые был предупрежден об этой проблеме, когда VMware сообщила мне, что у меня нет свопа. Я думал, что сделал, так как все, что я сделал, это обновить свой дистрибутив. В процессе обновления мой раздел не изменился вообще.

Я решил использовать свой gparted liveisk для форматирования той же области подкачки (которую вы увидите на фотографиях) в качестве linux-swap . Прежде чем я это сделал, Gparted livesisk дал ту же ошибку, что и он был непризнан. После завершения форматирования подкачки я перезапустил свой компьютер, чтобы узнать, что он не загрузился. На этот раз ошибка GRUB. Это никогда не случалось со мной раньше с дистрибутивами, делая аналогичную работу на диске.

Затем я решил сделать чистую установку 14.04 с USB и CD, но у меня все еще такая же проблема. Я попробовал (как вы увидите на фотографиях) также «swapon -a» из терминала без успеха (хотя я могу использовать swapon от Gparted в ОС) - я получаю ошибку в каталоге.

Это мой файл fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=a596c6cc-c9aa-43fe-aaad-abfeaae63916 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
#UUID=c4959ceb-5934-4cff-acd3-33ffcb153220 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

Я не знаю много того, что означает эта информация, но это может быть полезно для вас. Могу ли я перепутать свой своп, форматируя его в Gparted? Это было неизвестно в утилите, так как это был cryptswap.

Это мое текущее состояние. Как я уже сказал, мне нужно «swapon» при каждом перезапуске.

Я использовал Ubuntu как двойную загрузку уже несколько лет. С 6.06 «Даппер». Я использовал почти каждый дистрибутив и никогда раньше не сталкивался с этой проблемой. Здесь я прошу вас о вашей помощи и внушении. Я не выродка, только энтузиаст, и у меня есть базовые навыки и умения.

    
задан srgntpepprs 27.04.2014 в 04:57
источник

1 ответ

4

Откройте терминал и запустите эту команду:

sudo blkid

Это даст вам UUID no's разделов вашего жесткого диска из них, отметив раздел UUID раздела подкачки.

Теперь перейдите в файл fstab как root в этом файле, перейдите к строке под «# swap был включен / dev / sda6 во время установки» замените номер UUID под swap тем, который вы получили от команды blkid

Удалите символ '#' перед UUID, это означает, что строка не будет запущена, поэтому удалите ее.

Также полностью удалите приведенную ниже строку /dev/mapper/cryptswap1 none swap sw 0 0

Теперь перезагрузитесь.

Я надеюсь, что это поможет.

    
ответ дан Sudheer 08.05.2014 в 01:25