Как установить PostgreSQL 9.6 на любую версию Ubuntu?

75

Как установить PostgreSQL 9.6 на любую версию Ubuntu, поскольку она не появляется по умолчанию с самой последней версией?

Ubuntu Xenial (16.04) поставляется с PostgreSQL 9.5 из репозиториев по умолчанию.

    
задан Victor 29.09.2016 в 19:38
источник

3 ответа

148

Для следующих версий Ubuntu вы можете установить с данными командами в соответствии с официальным репозиторием PostgreSQL Apt .

Ubuntu 17.04 - 17.10

Версия 9.6 поставляется с дистрибутивом.

sudo apt-get install postgresql-9.6

Ubuntu 12.04, 14.04, 16.04

sudo add-apt-repository "deb http://apt.postgresql.org/pub/repos/apt/ $(lsb_release -sc)-pgdg main"
wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update
sudo apt-get install postgresql-9.6
    
ответ дан Victor 29.09.2016 в 19:38
источник
9

Следуйте инструкциям ниже:

Справка взято из этого блога.

Вам нужно добавить последний репозиторий PostgreSQL для последней версии.

sudo add-apt-repository "deb https://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main"

Обновление и установка PostgreSQL 9.6:

sudo apt-get update
sudo apt-get install postgresql-9.6

Создана база данных postgres super user и postgres. Вам нужно установить пароль для суперпользователя postgres.

ubuntu@:~$ sudo passwd postgres
Enter new UNIX password:****
Retype new UNIX password:****
passwd: password updated successfully

Если служба не запущена, вы можете запустить службу PostgreSQL.

sudo service postgresql start

Подключить сервер PostgreSQL с помощью пользователя postgres:

ubuntu@:~$ su postgres
Password:****

Создать образец базы данных:

createdb database_name

Подключиться к этой базе данных:

psql -d database_name
    
ответ дан Anvesh 18.01.2017 в 22:24
источник
1

Я последовал за этим Github gist - Я запускаю ubuntu xenial внутри vagrant и хотел обновить существующий постресурсный репозиторий vesion 9.5 до 9.6, чтобы я мог использовать расширение PostGIS , которое лучше всего обслуживается версия 9.6 (официально упомянутая на их сайте) Надеюсь, это поможет кому-то.

    
ответ дан Sanchit 24.06.2017 в 16:09
источник

Ознакомьтесь с другими вопросами по меткам