Как отключить клавиши F1 и F10 в gnome-терминале?

112

Как отключить привязки клавиш F1 (help) и F10 (уведомления)?

Сначала мне нужна утилита экрана, а вторая - для выхода из mc в консоли.

В настройках Клавиатурные сокращения нет таких привязок клавиш.

    
задан Marko Kevac 27.04.2011 в 15:55
источник

14 ответов

103

11.04

Отключить ярлык F1

  1. В открывшемся gnome-терминале Изменить ➜ Сочетания клавиш .

  2. Прокрутите вниз до ярлыка Справка / Содержание , нажмите там, где указано «F1», и нажмите Backspace :

Отключение ярлыка F10

  1. Установите compizconfig-settings-manager .

  2. Откройте Диспетчер настроек CompizConfig .

    • Нажмите Super , чтобы открыть Dash, введите «Compiz» и нажмите Enter .
  3. Введите «единство» в записи Фильтр и выберите Ubuntu Unity Plugin .

  4. Нажмите кнопку справа от клавиши , чтобы открыть первое меню панели , и снимите флажок Включено .

  5. Отключен глобальный ярлык F10 , теперь отключите ярлык gnome-terminal>:

    • В открывшемся gnome-терминале Сочетания клавиш ( Изменить ➜ Сочетания клавиш) и
      снимите флажок Включите клавишу быстрого доступа к меню (по умолчанию F10)

  6. F10 сопоставляется с menubar_accel чем-то в Ubuntu. Гном? Metacity? Не уверен, что это такое, что крадет его, но ключ не попадает в Eclipse.

    • Запустите gconf-editor, перейдите к / desktop / gnome / interface, затем прокрутите вниз до menubar_accel и удалите значение F10. [Украдены отсюда]
ответ дан Isaiah 23.06.2011 в 20:52
источник
43

Отключить F10 в терминале gnome в 12.04

Введите это в консоли:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Затем закройте все сеансы терминала. Теперь он должен работать так, как должен (например, в mc ).

ответ дан Paweł Gościcki 30.04.2012 в 21:25
источник
23

запустите gconf-editor и следуйте за /apps/gnome-terminal/keybindings/help

Описание:

«Клавиша быстрого доступа к клавиатуре для запуска справки. Выражена в виде строки в том же формате, что и для файлов ресурсов GTK +. Если вы установите параметр для специальной строки« отключено », то для этого действия не будет ярлыка клавиш».     

ответ дан Rinzwind 21.08.2011 в 22:28
источник
7

Я новичок в Linux, и этот ключ F10 сводит меня с ума. Все вышеприведенные трюки не сработали, но теперь я нашел решение (для Ubuntu 11.10 с классическим настольным компьютером Gnome 3). В терминале введите следующую команду:

gsettings set org.gnome.desktop.interface menubar-accel ""

С dconf-редактором можно найти, что F10 действительно ушел. Обратите внимание, что эти трюки, похоже, сильно зависят от версии Gnome / Ubuntu.

    
ответ дан gast128 29.11.2011 в 20:34
источник
4

Для выхода из mc (клавиша F10). Отключите «Ключ для открытия первого меню панели» в единственном модуле compiz (ccsm)

    
ответ дан kholis 29.04.2011 в 12:33
источник
4

@kholis является правильным для отключения F10 в Unity, но если вы новичок, как я, вам нужно немного больше информации, чтобы сделать эту работу.

Если вы еще не установили, установите compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Запустите новый установленный менеджер настроек и отфильтруйте для «единства»

Изменить ", чтобы открыть первое меню панели", чтобы отключить его или изменить на другую клавишу.

Я еще не нашел способ изменить F1.

ответ дан Ryan Sorensen 30.04.2011 в 19:36
источник
3

Инструкция на ссылке (приведенная ниже) также работает в Ubuntu 11.04. (Кажется, это отключает F1 как на рабочем столе, так и на терминале. То есть F1 не отправляет ansi-последовательность в оболочку в терминале, если это то, что хотел OP.)

  
  1. Перейдите в раздел «Настройки системы» - «Ярлыки клавиш»
  2.   
  3. Создать новый ярлык. Назовите его «ничего не делать» и напишите «false»,   (без кавычек) в поле «команда». Нажмите ok.
  4.   
  5. Перейдите к нижней части списка и найдите новую команду. Нажмите   на «Отключено», справа, и нажмите F1.
  6.   
    
ответ дан David Andersson 22.08.2011 в 04:12
источник
3

Вы можете легко отключить его, используя CCSM (нажмите, чтобы установить, если у вас его нет ).

Затем перейдите в Рабочий стол - & gt; Плагин Ubuntu Unity - & gt; Клавиша, чтобы открыть первое меню панели и отключить его, или изменить его на другую комбинацию клавиш.

Примечание : кажется, что этот метод не работает в Unity2D.     

ответ дан Binarylife 27.10.2011 в 00:03
источник
2

Это подсказка для пользователей Thnkpad, особенно T60. Удалите клавишу F1, чтобы выйти. Это устраняет раздражающее всплывающее окно помощи терминала, когда вы нажимаете F1. Вы часто это делаете из-за забавного размещения ESC на T60.

    
ответ дан ncmathsadist 03.12.2011 в 18:42
источник
1

Если вы хотите изменить это только в Gnome Terminal , вы можете нажать «Редактировать» и «Горячие клавиши» в терминале.

    
ответ дан Jeremy Bicha 30.04.2011 в 20:37
источник
1

Я рекомендую использовать F1 как ярлык для чего-то другого. Я запускаю Tilda, терминал командной строки в стиле землетрясения, а ярлык по умолчанию - F1. Он переопределяет Help, поэтому у меня никогда не появляется Help, когда я нажимаю F1. Даже если вам не нравится Тильда много, ударив F1 еще раз, чтобы скрыть, это гораздо менее утомительно, чем закрытие справки после его случайного запуска.

    
ответ дан titaniumtux 03.12.2011 в 20:23
источник
1

12.04

F1 , похоже, ничего не делает из коробки 12.04
F10 появляется, чтобы имитировать правую кнопку мыши

Поэтому в ответ на специфику вопроса нет необходимости отключать помощь и уведомления.

Вы все равно можете сопоставить их с чем-то еще следующим:
Сопоставление горячих клавиш в 12.04 просто осуществляется с помощью виджета «Клавиатура».

В Unity launcher найдите клавиатуру.

В открывшемся окне выберите вкладку ярлыков и пользовательские ярлыки.
Нажмите «Добавить», чтобы добавить новый ярлык.

Назовите его в соответствии с тем, что соответствует назначенным им функциям.
Введите команду, которую вы хотите запустить в команде.

В правой части окна щелкните, где указано, что отключено. Это должно переключиться на новый ускоритель.

Теперь просто нажмите F10 .
Выбранный ускоритель Custom Shortcuts переопределяет поведение моделирования правой кнопкой мыши. Вы можете установить эту команду в echo 'nope' > /dev/null , если хотите, чтобы ваш F10 ничего не делал.

    
ответ дан RobotHumans 02.04.2012 в 19:50
источник
1

12.04 Без Unity - отключить поведение F1 и F11

Я установил Ubuntu 12.04 / 64 и полностью удалил Unity из него, следуя этим указаниям . Поэтому многие из инструментов, которые изменяют поведение Unity, не работают. В частности, CCSM больше не видит «быстрых клавиш».

Я обнаружил, что метод с использованием Edit- & gt; Сочетания клавиш в окне терминала также не работал. Немного поиграв, я обнаружил, что дальше в окне Keyboard Shortcuts в разделе Shortcut Keys клавиши F1 и F11 все еще были определены в соответствующих ярлыках.

Чтобы исправить это,

  1. Нажмите «F11» в правом поле строки, которая определяет F11 в качестве полноэкранного режима. Текст изменится на «Новый ускоритель ...».

  2. Введите некоторые другие, менее вызывающие возражения последовательности клавиш (например, alt-F11) и эта комбинация клавиш заменит ярлык. Если кто-то знает, как набрать «ничего», пожалуйста, сообщите нам.

  3. Повторите для клавиши F1.

ответ дан Wes Miller 20.11.2013 в 17:33
источник
0

Ctrl + F1 тоже не работает. Решение такое же, как для Shift + F10. Не забывайте точку с запятой как разделитель!

Поместите это в ~ / .config / gtk-3.0 / gtk.css:

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10";
     unbind "<control>F1";
}

* {
     gtk-key-bindings: NoKeyboardNavigation;
}
    
ответ дан egmont 16.03.2014 в 12:46
источник

Ознакомьтесь с другими вопросами по меткам