Как установить Adobe Flash Player?

99

У меня были серьезные проблемы с просмотром флеш-видео в 64-битном Ubuntu. Кто-нибудь знает, как получить флеш-память на платформе?

    
задан Steven Oxley 28.07.2010 в 21:27
источник

20 ответов

80

Для 11.04 и более ранних версий:

Вы устанавливаете его из программного центра Ubuntu?

  1. Перейдите в Application- & gt; Центр программного обеспечения Ubuntu.
  2. Нажмите на Canonical Partners
  3. Щелкните плагин Adobe Flash 11 и нажмите кнопку «Установить».

Примечание. это метод, который я использую в своей 64-разрядной установке Ubuntu, но он еще не смог меня.

    
ответ дан Nathan Osman 28.07.2010 в 21:31
источник
68

Для 11.10 и более поздних

Запустите Software Center из Launcher и выполните поиск flash

Две записи будут найдены. Первый - это обертка вокруг 32-битной флеш-версии от Adobe. Вторая версия - 64-битная версия флэш-памяти.

Выберите вторую запись вспышки - если отображается следующее изображение, вы ранее не включили репозиторий Canonical Partner.

Нажмите Подробнее

... и нажмите Использовать этот источник , чтобы включить репозиторий Canonical Partner

см. конец этого ответа для отчета об ошибке

Нажмите Установить

Нажмите кнопку Установить и введите пароль при появлении запроса. Примечание. У вас должно быть разрешение на установку программного обеспечения.

Установка продолжится:

После завершения - запустите Firefox и перейдите на Flash Video. Щелкните правой кнопкой мыши и убедитесь, что последняя версия Flash установлена ​​правильно.

Примечание. Изображения могут быть изменены. 64-разрядная версия была недавно упакована за последнюю неделю до выпуска Oneiric. В настоящее время существует одна проблема:

  1. Ссылка

В промежутке - либо используйте первый 32-битный плагин Multiverse на приведенных выше рисунках, либо используйте adobe-flashplugin

sudo apt-get install adobe-flashplugin
    
ответ дан fossfreedom 10.10.2011 в 00:52
источник
30

Вот как установить Adobe Flash Plugin для Firefox:

  1. Перейдите на страницу этого и выберите вариант .tar.gz для другого Linux. Загрузите файл.
  2. Распакуйте плагин tar.gz и скопируйте файлы в соответствующее место.
  3. Сохраните плагин tar.gz локально и обратите внимание на местоположение, в которое был сохранен файл.
  4. Запустите терминал и смените каталоги на папку, в которую был сохранен файл.
  5. Распакуйте файл tar.gz. После распаковки вы увидите следующее:

    • libflashplayer.so
    • / usr
  6. Определите расположение каталога плагинов браузера на основе вашего дистрибутива Linux и версии Firefox (обычно это /usr/lib/mozilla/plugins/ )
    Для пути ubuntu 14.04 : /usr/lib/firefox/browser/plugins

  7. Скопируйте libflashplayer.so в соответствующий каталог плагинов браузера. В командной строке введите:

    sudo cp libflashplayer.so <BrowserPluginsLocation>
    
  8. Скопируйте файлы конфигурации локальных настроек Flash Player в каталог / usr. В командной строке введите:

    sudo cp -r usr/* /usr
    
  9. Теперь перезагрузите браузер.

ответ дан ignite 04.09.2012 в 18:36
источник
21

Поскольку вы заявили, что это первый раз, когда вы когда-либо использовали ubuntu. я бы предположил, что вы устанавливаете пакет ubuntu-limited-extras, это включает в себя множество полезных вещей, таких как flash-флеш-память, кодеки и шрифты MS и т. д.

вы можете сделать это разными способами.

программный центр: нажмите на эту ссылку:

или в терминале: введите sudo apt-get install ubuntu-restricted-extras

synaptic: найдите пакет ubuntu-limited-extras, щелкните правой кнопкой мыши пакет и выберите установку, а затем выберите отметку. после нажатия кнопки «Применить», и все будет установлено.     

ответ дан Terry 02.04.2011 в 16:02
источник
13

Существует простое решение этой проблемы.

Откройте Firefox и перейдите на Youtube . Нажмите на любое видео. Определенно это не будет играть, потому что у вас нет установленного flash-плеера. Но Firefox будет продвигать вас до install missing plug-in вверху. Просто нажмите на нее и выполните процедуру. После этого начнется воспроизведение вашего видео. Убедитесь, что установлен последний браузер Firefox .

Или попробуйте это в терминале

sudo apt-get install flashplugin-installer
    
ответ дан Kaktarua 04.09.2012 в 18:38
источник
5

Получите расширение Flash-Aid для Firefox. Он позаботится о загрузке и установке соответствующей версии вашей системной архитектуры, а также удалит конфликтующие плагины. Если вы находитесь на 64-битной версии, она также позволяет установить 64-битную версию предварительного просмотра, которая обеспечивает лучшие результаты, чем 32-разрядный с помощью nspluginwrapper.

Кстати, если вы не можете скопировать что-либо в папку ~ / .mozilla / plugins, тогда вы должны проверить право собственности на папку ~ / .mozilla. Это должно позволить копировать что-нибудь там. Если, конечно, вы не обращаетесь к системной папке вне вашего домашнего каталога, которая требует привилегий root.

    
ответ дан lovinglinux 02.12.2010 в 13:40
источник
4

Это зависит от того, какой браузер вы используете. Google Chrome (не Chromium) по умолчанию имеет проигрыватель Flash.

Перейдите на сайт www.google.com/chrome и нажмите кнопку загрузки. Выберите 64-разрядный .deb (любой, кто читает это с использованием 32-разрядных машин, должен выбрать 32-разрядный .deb)

Когда вы нажмете на файл .deb, когда он будет загружен, он откроется в Центре программного обеспечения. Теперь нажмите «Установить», и по завершении вы можете найти браузер в Приложениях - & gt; Интернет.

    
ответ дан Mozart321 02.04.2011 в 22:00
источник
2

Используйте программный центр Ubuntu (в меню «Приложения»). В поле ввода текста (в поле поиска) вы можете выполнить поиск «flash», и в результате будет заполнен один плагин Adobe Flash (обратите внимание на логотип Adobe). Выберите это и следуйте инструкциям по использованию источника.

    
ответ дан Daniel T Chen 01.12.2010 в 20:14
источник
2

Двойная проверка, какой каталог «плагин» используется. Пришлось провести хороший час один раз, просто вспахивая все каталоги плагинов, пока не найду те, на которых мой firefox действительно читал, а затем ln -s их всех указывали на общий.

В конце дня вы можете сбросить его в неправильном месте.

Также запустите firefox из командной строки, вы можете увидеть ошибки. Например, работает x86-флеш-плеер в браузере x64 (не os) и наоборот. Из командной строки ( %> firefox ) вы должны увидеть строки журнала инициализации плагина. (возможно, сначала попробуйте это: P)

Также что-либо в /usr/lib/... принадлежит root, поэтому вам нужно будет sudo cp libflashplayer.so /usr/lib/firefox/plugin , где .../firefox/plugin указывает на расположение каталога плагина firefox.

    
ответ дан Dmitriy Likhten 01.12.2010 в 20:51
источник
2

Определенное исправление для 64-битной вспышки 11.10

Я исправил 64-битную Flash на своих системах 11.10 без каких-либо оберток. Если вы будете следовать упомянутым выше решениям, вы все равно получите 32-битную версию и обертки.

Примечание: большую часть этого можно сделать и в терминале, в этом случае вам не нужно устанавливать Synaptic. Кроме того, может быть, достаточно просто выполнить шаги 5, 6 и 8, но я еще не тестировал это.

  1. Установите Synaptic (Центр программного обеспечения не отображает необходимый пакет, а не основные элементы, а не в технических элементах и ​​даже после его установки).
  2. Запустите Synaptic и найдите «flash»
  3. Сортировка по установленному состоянию
  4. Удалите все связанные со вспышкой пакеты (такие как flashplugin-downloader: i386, flashplugin-installer, ndiswrapper-common и т. д.). Если в списке ничего нет, у вас, вероятно, нет установленной Flash. В этом случае просто перейдите к следующему шагу.
  5. Включить репозиторий партнеров Canonical (см. выше сообщения о том, как это сделать)
  6. Обновите список пакетов (не считайте, что Software Center сделает это за вас, иногда это не так), нажав кнопку «Обновить» в
  7. Ищите «flash» снова
  8. Установите пакет «adobe-flashplugin». Если этого нет в списке, что-то пошло не так с обновлением списков пакетов. Попробуйте выйти из системы и перезапустить Synapic, затем нажмите «Перезагрузить».

Один дополнительный пакет, «adobe-flash-properties-gtk» будет установлен автоматически. Ничего больше.

Теперь у вас будет полная 64-битная Flash без каких-либо оберток и другой мусор в Firefox и Chromium. Однако требуется перезапуск вашего браузера. Если он все еще не работает, попробуйте перезагрузиться (там может быть какая-то фиктивная ссылка на старые плагины).

    
ответ дан iGadget 12.11.2011 в 13:18
источник
2
sudo apt-get remove --purge adobe-flashplugin flashplugin* nspluginwrapper
sudo apt-get install --reinstall adobe-flashplugin

Ссылка: Ссылка     

ответ дан Coc 20.11.2011 в 11:21
источник
2

Вот что вам нужно сделать: по умолчанию Ubuntu поставляется с включенным только программным обеспечением с открытым исходным кодом (я думаю, это так, во всяком случае).

То, как вы включаете другие вещи (например, Flash, Java и поддержку для записи или воспроизведения MP3-файлов, что НЕ является открытым исходным кодом) заключается в том, чтобы зайти в ваш программный центр, зайти в меню (к сожалению, я сейчас не на Ubuntu и не может сказать вам, какое меню) и искать источники программного обеспечения.

Щелкните по нему, и вы попадете в окно, в котором сообщается Ubuntu, что вам разрешено устанавливать для вас. Перед вами должен быть список из пяти разных «вселенных». Что вам нужно сделать, это включить два, которые в настоящее время не включены.

После этого он должен спросить вас, хотите ли вы перезагрузить свои репозитории, но если это не так, войдите в командную строку и введите

sudo apt-get update

и пусть это закончится. Затем вы можете найти вспышку в Центре программного обеспечения или в командной строке. Вы также можете установить пакет ubuntu-limited-extras, который предоставит вам все три вещи, о которых я говорил выше.

Удачи!

    
ответ дан Noah 04.09.2012 в 18:14
источник
2

Я рассмотрел множество возможных предложений, которые я смог найти, пытаясь заставить флеш работать в Chrome на моей 13.10-64-битной установке. Ничего не получилось. Я, наконец, наткнулся на ответ Pepper Flash.

Существуют полные и хорошо написанные инструкции (ссылка прямая)

ubuntuhandbook.org

Они подробно добавляют репозиторий, обновляют apt, устанавливают Pepper и изменяют конфигурацию chrome. То, что я сделал иначе, чем их инструкции, заключалось в том, чтобы перейти в каталог / etc / chromium-browser и выдать команду

sudo gedit default

, который позволил мне добавить комментарий к файлу в дополнение к необходимой информации .sh, поэтому последние пару строк моего модифицированного файла по умолчанию:

# enable Pepper Flash Player Plugin
. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Надеемся, что это решение будет работать в течение некоторого времени.     

ответ дан zenpistolero 03.05.2014 в 01:58
источник
2

Flash-видео не будет воспроизводиться на новой установке Ubuntu 14.04, даже если adobe-flashplugin из репозитория «партнер» - получило черный экран на YouTube (за исключением того, что , чтобы использовать HTML5 ), dailymotion и т. д. Установка freshplayerplugin (видимо, обертка для флеш-проигрывателя Chrome) решила проблему:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin
    
ответ дан Skippy le Grand Gourou 22.08.2015 в 09:33
источник
1

В случае, если

sudo apt-get install flashplugin-nonfree

не работает (как в моем случае, и я не знаю, почему ...), вы можете попробовать Opera в качестве браузера. Это единственное, что работает для меня.

PS: Я не хочу рекламировать браузер Opera, просто это единственное решение, которое каким-то образом сработало для меня.

    
ответ дан Remi Meier 14.08.2010 в 15:19
источник
1

Я только что нашел решение для тех, кто работает в Firefox, но не на Chromium. Это основано на том, что у каждого браузера есть собственный каталог плагинов:

  • / usr / lib / firefox-addons / plugins (для Firefox)
  • / usr / lib / chromium-browser / plugins (для Chromium)

Итак, единственное, что вам нужно сделать, это унифицировать их, ака, сделав одну ссылку на другую. Вероятно, все плагины находятся в каталоге плагинов Firefox, но не стоит гарантировать, что:

ls -l /usr/lib/{mozilla,chromium-browser}/plugins

Если Firefox - это тот, где все плагины, сделайте следующее. Если нет, сделайте обратное:

sudo rmdir /usr/lib/chromium-browser/plugins
sudo ln -s /usr/lib/mozilla/plugins /usr/lib/chromium-browser/

Наконец, перезапустите Chromium, чтобы изменения вступили в силу.

Вероятно, неплохо было бы создать отчет об ошибках для сопровождающих пакетов Chromium / Firefox, чтобы предупредить об ошибке и простом решении.

    
ответ дан emi 16.08.2012 в 19:19
источник
1

Хорошо, я публикую это здесь, в надежде помочь кому-то. Я расскажу, что происходит и как я это решил.

SETUP:
    Запуск 12.04 с установки WUBI.

Проблема:
    Когда я искал в программном центре Ubuntu ключевое слово flash , ни один из вариантов, опубликованных здесь, не появился, кроме ONE для flash plugin для Mozilla. При попытке установить его я получил ошибку зависимостей.

Пробовал установить его через Ubuntu Restricted Extras из Ubuntu Software Center, однако часть плагина Flash этой установки не работала из-за ошибки зависимостей.

Не удалось найти и найти эту команду для установки плагина

sudo apt-get install flashplugin-nonfree

и запустил его с терминала.

Аналогичная ошибка зависимости с этим выходом:

Reading package lists... Done Building dependency tree        
Reading state information... Done Note, selecting 'flashplugin-installer' instead of 'flashplugin-nonfree' 
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. 
The following information may help to resolve the situation:
The following packages have unmet dependencies:  
 flashplugin-installer : 
 Depends: libnspr4-0d but it is not going to be installed E: Unable to correct problems, you have held broken packages.

РЕШЕНИЕ:

Я побежал

sudo apt-get install -f 

, а затем

sudo apt-get update 

, который я нашел из другого сообщения, которое пыталось решить зависимости.

Затем я запустил

sudo apt-get install flashplugin-nonfree

и плагин flash теперь работает на Chromium и Firefox.

    
ответ дан Joel 02.10.2012 в 17:55
источник
1

Это зависит от того, как вы устанавливаете. это через файл tar.gz или rpm или какой-либо другой метод. Есть несколько способов получить вспышку.

Download link: https://get.adobe.com/flashplayer/

Installation instructions
-------------------------

Installing using the plugin tar.gz:
    o Unpack the plugin tar.gz and copy the files to the appropriate location.  
    o Save the plugin tar.gz locally and note the location the file was saved to.
    o Launch terminal and change directories to the location the file was saved to.
    o Unpack the tar.gz file.  Once unpacked you will see the following:
        + libflashplayer.so
        + /usr
    o Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version
    o Copy libflashplayer.so to the appropriate browser plugins directory.  At the prompt type:
        + cp libflashlayer.so <BrowserPluginsLocation>
    o Copy the Flash Player Local Settings configurations files to the /usr directory.  At the prompt type:
        + sudo cp -r usr/* /usr

Installing the plugin using RPM:
   o As root, enter in terminal:
          + # rpm -Uvh <rpm_package_file>
          + Click Enter key and follow prompts

Installing the standalone player:
   o Unpack the tar.gz file
   o To execute the standalone player,
          + Double-click, or 
          + Enter in terminal: ./flashplayer

Bonus:

Uninstallation instructions
---------------------------

Manual uninstallation (for users who installed the plugin via Install script):
   o Delete libflashplayer.so binary and flashplayer.xpt file in 
   directory /home/<user>/.mozilla/plugins/

RPM uninstallation:
   o As root, enter in terminal:
          + # rpm -e flash-plugin
          + Click Enter key and follow prompts
    
ответ дан Revanth Kumar 02.05.2015 в 03:59
источник
0

Я проверил много ответов на эту тему на прошлой неделе. Наконец, я нашел ссылку с решением, которое работает:

Ссылка

В принципе, ответ заключается в том, что он, кажется, удаляется из всех источников программного обеспечения, и вам нужно загрузить старую версию и установить ее вручную.

    
ответ дан palbeda 12.04.2017 в 16:33
источник
0
  

Linux больше не поддерживает Adobe Flash Player в своем магазине. Поэтому вам нужно сделать это вручную.

  

Это проверяется только на Firefox, если у вас есть Chrome / Chromium, вам не нужно его устанавливать.

Существует процедура ручной установки Adobe Flash Player на Ubuntu, выполните следующие действия: -

  1. Откройте эту ссылку . Он автоматически предложит вам версию в соответствии с вашей рабочей средой.

  2. Выберите опцию .tar.gz for Linux , как показано на рисунке ниже.

  3. Теперь нажмите Кнопка загрузки (выберите удобный путь для загрузки в качестве Загрузки ).

  4. Теперь извлеките файл Right clicking в папку и выберите Extract Here .

  5. Откройте Терминал CTRL+ALT+T и скопируйте ниже команду один за другим

    5,1. % Co_de%

    5.2. cd ../ (например, paper96)

    5,3. cd your-pc-name (это папка, в которой вы загрузили файл в Вариант 3 ).

    5,4. cd Downloads (Имя вашего файла может отличаться только от копирования имени файла и вставки его в терминал)

    5,5. cd flash_player_npapi_linux.x86_64 hit enter и thats it.

  6. Теперь закройте браузер (Firefox) и терминал.

  7. Перезагрузите Firefox, и теперь у вас есть Flash Player в вашем браузере. Посетите эту ссылку для подтверждения.

ответ дан Pankaj Gautam 17.07.2017 в 09:52
источник

Ознакомьтесь с другими вопросами по меткам